summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorSahithi Yarlagadda <sahi@swecha.net>2018-03-20 07:38:55 +0530
committerRicardo Wurmus <rekado@elephly.net>2018-03-20 15:00:52 +0100
commitc56739df6bdc4fc8c652fc4bb0b49d8d83a23dee (patch)
treec1a4d465262fed1a8a7744fbbd1e995f19075bed /gnu/packages/cran.scm
parent4f1e4f33a049ce1faae11f1da7a896a89e964ae7 (diff)
downloadguix-c56739df6bdc4fc8c652fc4bb0b49d8d83a23dee.tar.gz
gnu: Add r-dyn.
* gnu/packages/cran.scm (r-dyn): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index b54ddc6b55..749eed8b57 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -4,6 +4,7 @@
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Raoul Bonnal <ilpuccio.febo@gmail.com>
 ;;; Copyright © 2018 Vijayalakshmi Vedantham <vijimay12@gmail.com>
+;;; Copyright © 2018 Sahithi Yarlagadda <sahi@swecha.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3245,3 +3246,30 @@ how rivers split and merge.  For example, they can be used to compare
 different clusterings.  This package provides an implementation of Sankey
 plots for R.")
     (license license:gpl2+)))
+
+(define-public r-dyn
+  (package
+    (name "r-dyn")
+    (version "0.2-9.6")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "dyn" version))
+       (sha256
+        (base32
+         "16fqv9k7yxdgybwzafjkyqm16qpgqz13lcjpi6a1nc8xbzlzh0gb"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-zoo" ,r-zoo)))
+    (home-page "https://cran.r-project.org/web/packages/dyn")
+    (synopsis "Time series regression")
+    (description
+     "This package provides the dyn class interfaces @code{ts}, @code{irts},
+@code{zoo} and @code{zooreg} time series classes to @code{lm}, @code{glm},
+@code{loess}, @code{quantreg::rq}, @code{MASS::rlm},
+@code{MCMCpack::MCMCregress()}, @code{quantreg::rq()},
+@code{randomForest::randomForest()} and other regression functions, allowing
+those functions to be used with time series including specifications that may
+contain lags, diffs and missing values.")
+    ;; Any GPL version.
+    (license license:gpl2+)))