summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 18:49:05 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:39 +0100
commitc5b86d3a18fc671ee645dc8bfdaaced1a995ab2f (patch)
tree214f8b57e2ef5ef75797cbc289c6aa4143436c64 /gnu/packages/cran.scm
parentf9d9c83183c02a6d50fa0b277ec69a897def73bb (diff)
downloadguix-c5b86d3a18fc671ee645dc8bfdaaced1a995ab2f.tar.gz
gnu: Add r-accrual.
* gnu/packages/cran.scm (r-accrual): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 82403e5b42..0186fe7a52 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16708,3 +16708,33 @@ experienced.")
      "This package provides a series of additional Tcl commands and Tk widgets
 with style and various functions to supplement the tcltk package")
     (license license:lgpl3)))
+
+(define-public r-accrual
+  (package
+    (name "r-accrual")
+    (version "1.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "accrual" version))
+       (sha256
+        (base32
+         "11clm9s5c5518nmp6hd6pjnp0s28y92b2i2x0xgj4j5g816p4j3z"))))
+    (properties `((upstream-name . "accrual")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-fgui" ,r-fgui)
+       ("r-smpracticals" ,r-smpracticals)
+       ("r-tcltk2" ,r-tcltk2)))
+    (home-page "https://cran.r-project.org/web/packages/accrual/")
+    (synopsis "Bayesian accrual prediction")
+    (description
+     "Subject recruitment for medical research is challenging.  Slow patient
+accrual leads to delay in research.  Accrual monitoring during the process of
+recruitment is critical.  Researchers need reliable tools to manage the
+accrual rate.  This package provides an implementation of a Bayesian method
+that integrates researcher's experience on previous trials and data from the
+current study, providing reliable prediction on accrual rate for clinical
+studies.  It provides functions for Bayesian accrual prediction which can be
+easily used by statisticians and clinical researchers.")
+    (license license:gpl2)))