summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-04-21 09:22:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-04-21 23:07:52 +0200
commitce4e81cb868307ab9ab84c4b07596a57ad0e57c8 (patch)
treeb57afe14fb6fed7ce89d0029929aeb480119551c /gnu/packages/cran.scm
parentf1c7a2428044136b41a2cc6cd344c4c7c20d5a22 (diff)
downloadguix-ce4e81cb868307ab9ab84c4b07596a57ad0e57c8.tar.gz
gnu: Add r-magic.
* gnu/packages/cran.scm (r-magic): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index bddeb66660..2f4b2e5367 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1480,6 +1480,29 @@ Engineering and Computational Finance\" and for managing chronological and
 calendar objects.")
     (license license:gpl2+)))
 
+(define-public r-magic
+  (package
+    (name "r-magic")
+    (version "1.5-8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "magic" version))
+       (sha256
+        (base32
+         "083cgpp3v03li0h8597b3g21pd9lkbmn9pyssblnhc800mpc52vz"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-abind" ,r-abind)))
+    (home-page "https://github.com/RobinHankin/magic.git")
+    (synopsis "Create and investigate magic squares")
+    (description
+     "This package provides a collection of efficient, vectorized algorithms
+for the creation and investigation of magic squares and hypercubes, including
+a variety of functions for the manipulation and analysis of arbitrarily
+dimensioned arrays.")
+    (license license:gpl2)))
+
 (define-public r-ddalpha
   (package
     (name "r-ddalpha")