summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-03 16:46:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-03 22:29:40 +0100
commitdcf857e4864ea356a245df9dcfd67fdb9fd0217f (patch)
tree3960b61cf88e38725fe27de9559683cbf9a6a011 /gnu/packages/cran.scm
parent15404ff19b304bc9efcdb9a326318fb9fa9716da (diff)
downloadguix-dcf857e4864ea356a245df9dcfd67fdb9fd0217f.tar.gz
gnu: Add r-fpeek.
* gnu/packages/cran.scm (r-fpeek): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5f12cc55bf..8d585f0970 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -632,6 +632,28 @@ Currently handlers are provided for CDK, MOE and BCI fingerprint data.")
     ;; Any version of the GPL
     (license (list license:gpl2+ license:gpl3+))))
 
+(define-public r-fpeek
+  (package
+    (name "r-fpeek")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "fpeek" version))
+       (sha256
+        (base32 "0kv46g21ndxchg3q8ynq7hjjkh6i2zlc21axn5y1jjzigrw047ii"))))
+    (properties `((upstream-name . "fpeek")))
+    (build-system r-build-system)
+    (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+    (home-page "https://github.com/davidgohel/fpeek")
+    (synopsis "Check text files content at a glance")
+    (description
+     "This package provides tools to help working with text files.  It can
+return the number of lines; print the first and last lines; convert encoding.
+Operations are made without reading the entire file before starting, resulting
+in good performances with large files.")
+    (license license:expat)))
+
 (define-public r-ggalluvial
   (package
    (name "r-ggalluvial")