summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-13 13:30:58 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-13 22:41:36 +0100
commite44c4cd73cfb256c97a0f14f8b3731b35b024dd8 (patch)
treeb94e17f73f7601abd5e8b9c55e9029245db68e06 /gnu/packages/cran.scm
parentba4fcea499c74515925f2bc6a414ba64fff7754c (diff)
downloadguix-e44c4cd73cfb256c97a0f14f8b3731b35b024dd8.tar.gz
gnu: Add r-bio3d.
* gnu/packages/cran.scm (r-bio3d): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c2f0e156bd..1c3d40d76c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -16013,3 +16013,34 @@ graphics directly in the terminal window.  This package provides a basic
 plotting function (and equivalents of curve, density, acf and barplot) as well
 as a boxplot function.")
     (license license:lgpl3+)))
+
+(define-public r-bio3d
+  (package
+    (name "r-bio3d")
+    (version "2.4-0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "bio3d" version))
+       (sha256
+        (base32
+         "0ikpk1ppdp50m9kd289z616i382j9i7ji1zchyd4xqfyk8lnxf4s"))))
+    (properties `((upstream-name . "bio3d")))
+    (build-system r-build-system)
+    (inputs `(("zlib" ,zlib)))
+    (propagated-inputs `(("r-rcpp" ,r-rcpp)))
+    (home-page "http://thegrantlab.org/bio3d/")
+    (synopsis "Biological structure analysis")
+    (description
+     "This package provides utilities to process, organize and explore protein
+structure, sequence and dynamics data.  Features include the ability to read
+and write structure, sequence and dynamic trajectory data, perform sequence
+and structure database searches, data summaries, atom selection, alignment,
+superposition, rigid core identification, clustering, torsion analysis,
+distance matrix analysis, structure and sequence conservation analysis, normal
+mode analysis, principal component analysis of heterogeneous structure data,
+and correlation network analysis from normal mode and molecular dynamics data.
+In addition, various utility functions are provided to enable the statistical
+and graphical power of the R environment to work with biological sequence and
+structural data.")
+    (license license:gpl2+)))