summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-08-26 10:54:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-08-26 11:25:20 +0200
commite5f360aa97a39d1f3068f6aeef369b2e67c879fd (patch)
tree81db0c0d937247a52a61b6c234882252d15d33cd /gnu/packages/cran.scm
parentc410001d2132ac32740585660d4cda174b7369db (diff)
downloadguix-e5f360aa97a39d1f3068f6aeef369b2e67c879fd.tar.gz
gnu: Add r-zzlite.
* gnu/packages/cran.scm (r-zzlite): New variable.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 337ad2816d..5a9889f11e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -30347,3 +30347,30 @@ experimentation, supports both convolution based networks and recurrent
 networks (as well as combinations of the two), and runs seamlessly on both CPU
 and GPU devices.")
     (license license:expat)))
+
+(define-public r-zzlite
+  (package
+    (name "r-zzlite")
+    (version "0.1.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "zzlite" version))
+       (sha256
+        (base32
+         "0vi1slx2s4r5zf82lazqv0c3m12xq73wlgsbz6af4y00h0bkr3ps"))))
+    (properties `((upstream-name . "zzlite")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-httr" ,r-httr)
+       ("r-jsonlite" ,r-jsonlite)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
+    (home-page "https://cran.r-project.org/package=zzlite")
+    (synopsis "Wrapper for the Zamzar file conversion API")
+    (description
+     "This package provides a minor collection of HTTP wrappers for the Zamzar
+file conversion API.  The wrappers makes it easy to utilize the API and thus
+convert between more than 100 different file formats (ranging from audio
+files, images, movie formats, etc., etc.) through an R session.")
+    (license license:gpl3)))