summary refs log tree commit diff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-11 15:11:48 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-11 17:03:47 +0200
commited7fa0af07f7fa2f395e5c2eb07f9897844525c9 (patch)
tree6ab33acfb061ecc1e1228e43b8a04fd4c3242ff3 /gnu/packages/cran.scm
parent93043ba3377eb7c5565ec354a4875413f3a1e92d (diff)
downloadguix-ed7fa0af07f7fa2f395e5c2eb07f9897844525c9.tar.gz
gnu: r-europepmc: Update to 0.4.
* gnu/packages/cran.scm (r-europepmc): Update to 0.4.
[propagated-inputs]: Add r-rlang, r-tibble, and r-tidyr.
[native-inputs]: Add r-knitr.
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 88fa31891e..d4a4c5d553 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -14546,14 +14546,14 @@ that fills this gap.")
 (define-public r-europepmc
   (package
     (name "r-europepmc")
-    (version "0.3")
+    (version "0.4")
     (source
      (origin
        (method url-fetch)
        (uri (cran-uri "europepmc" version))
        (sha256
         (base32
-         "1ngqs1sqzkbwv98dd5z4cxj8bnz41wyd0g060a2vpqi3s99s4i2h"))))
+         "174nnyc2mbgqxb5kgqabn1vf71c2mps7ig2bclq4is0f7nb64pym"))))
     (build-system r-build-system)
     (propagated-inputs
      `(("r-dplyr" ,r-dplyr)
@@ -14562,8 +14562,13 @@ that fills this gap.")
        ("r-plyr" ,r-plyr)
        ("r-progress" ,r-progress)
        ("r-purrr" ,r-purrr)
+       ("r-rlang" ,r-rlang)
+       ("r-tibble" ,r-tibble)
+       ("r-tidyr" ,r-tidyr)
        ("r-urltools" ,r-urltools)
        ("r-xml2" ,r-xml2)))
+    (native-inputs
+     `(("r-knitr" ,r-knitr)))
     (home-page "https://github.com/ropensci/europepmc/")
     (synopsis "R Interface to the Europe PubMed Central RESTful Web Service")
     (description