summary refs log tree commit diff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-21 15:50:19 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:59 +0200
commit5cd8f451eac6d6254d4ae527bdcd715730228689 (patch)
tree096e829a90cfd4c5f78a50e9e9413ebb70ad8707 /gnu/packages/crates-crypto.scm
parente2a7867ad5de8dd84a554783006a997c4ba0fdf6 (diff)
downloadguix-5cd8f451eac6d6254d4ae527bdcd715730228689.tar.gz
gnu: rust-argon2-0.5: Move to (gnu packages crates-crypto).
* gnu/packages/crates-io.scm (rust-argon2-0.5): Move from here ...
* gnu/packages/crates-crypto.scm: ... to here.

Change-Id: I34fa8c10c4ab6e1f871230a289e6afe84148df28
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 56ae4c58df..0ccac7d587 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -525,6 +525,36 @@ This package is deprecated and was replaced by the @code{aes} crate.")
         ("rust-opaque-debug" ,rust-opaque-debug-0.2)
         ("rust-stream-cipher" ,rust-stream-cipher-0.3))))))
 
+(define-public rust-argon2-0.5
+  (package
+    (name "rust-argon2")
+    (version "0.5.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "argon2" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "1y820hkza66lfliaxg49zskz7agj8wf7aak528livg261an4rfhp"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-base64ct" ,rust-base64ct-1)
+        ("rust-blake2" ,rust-blake2-0.10)
+        ("rust-cpufeatures" ,rust-cpufeatures-0.2)
+        ("rust-password-hash" ,rust-password-hash-0.5)
+        ("rust-zeroize" ,rust-zeroize-1))
+       #:cargo-development-inputs
+       (("rust-hex-literal" ,rust-hex-literal-0.4)
+        ("rust-password-hash" ,rust-password-hash-0.5))))
+    (home-page
+     "https://github.com/RustCrypto/password-hashes/tree/master/argon2")
+    (synopsis "Rust argon2 library")
+    (description
+     "Pure Rust implementation of the Argon2 password hashing function with support
+for the Argon2d, Argon2i, and Argon2id algorithmic variants.")
+    (license (list license:expat license:asl2.0))))
+
 (define-public rust-blake2-0.10
   (package
     (name "rust-blake2")