summary refs log tree commit diff
path: root/gnu/packages/crates-graphics.scm
diff options
context:
space:
mode:
authorAleksandr Vityazev <avityazew@gmail.com>2023-10-07 03:02:28 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-10-22 14:53:10 +0300
commitc6f6f339a51dfa72c47a1df80eedd38985bbb683 (patch)
tree1a1fe3e4b450c5028130ad4cdffb9d43615df7f8 /gnu/packages/crates-graphics.scm
parentc94337e1aa1c08ff7b21febf269e6fb2d7c1c7bb (diff)
downloadguix-c6f6f339a51dfa72c47a1df80eedd38985bbb683.tar.gz
gnu: Add rust-wayland-client-0.30.
* gnu/packages/crates-graphics.scm (rust-wayland-client-0.30): New
variable.
(rust-wayland-client-0.29): Inherit from rust-wayland-client-0.30.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/crates-graphics.scm')
-rw-r--r--gnu/packages/crates-graphics.scm45
1 files changed, 36 insertions, 9 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index 0935b5c2d3..17fd7f67c7 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -2679,8 +2679,43 @@ applications.")
 protocol.")
     (license license:expat)))
 
+(define-public rust-wayland-client-0.30
+  (package
+    (name "rust-wayland-client")
+    (version "0.30.2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "wayland-client" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1j3as2g1znrs2lpkksqcvx8pag85yiwwbcv6wb3lyrqgfxa9d728"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f      ; use of undeclared crate or module `wayland_protocols`
+       #:cargo-inputs
+       (("rust-bitflags" ,rust-bitflags-1)
+        ("rust-calloop" ,rust-calloop-0.10)
+        ("rust-log" ,rust-log-0.4)
+        ("rust-nix" ,rust-nix-0.26)
+        ("rust-wayland-backend" ,rust-wayland-backend-0.1)
+        ("rust-wayland-scanner" ,rust-wayland-scanner-0.30))
+       #:cargo-development-inputs
+       (("rust-futures-channel" ,rust-futures-channel-0.3)
+        ("rust-futures-util" ,rust-futures-util-0.3)
+        ("rust-tempfile" ,rust-tempfile-3))))
+    (home-page "https://github.com/smithay/wayland-rs")
+    (synopsis
+     "Rust bindings to the standard C implementation of the wayland protocol")
+    (description
+     "This package provides Rust bindings to the standard C implementation of
+the wayland protocol, client side.")
+    (license license:expat)))
+
 (define-public rust-wayland-client-0.29
   (package
+    (inherit rust-wayland-client-0.30)
     (name "rust-wayland-client")
     (version "0.29.5")
     (source
@@ -2690,7 +2725,6 @@ protocol.")
        (file-name (string-append name "-" version ".tar.gz"))
        (sha256
         (base32 "05b7qikqj22rjy17kqw5ar7j2chpy18dr0gqapvwjfd00n60cfrz"))))
-    (build-system cargo-build-system)
     (arguments
      `(#:tests? #false               ;circular dependency on wayland-protocols
        #:cargo-inputs
@@ -2712,14 +2746,7 @@ protocol.")
            rust-scoped-tls-1
            rust-wayland-commons-0.29
            rust-wayland-scanner-0.29
-           rust-wayland-sys-0.29))
-    (home-page "https://github.com/smithay/wayland-rs")
-    (synopsis
-     "Rust bindings to the standard C implementation of the wayland protocol")
-    (description
-     "This package provides Rust bindings to the standard C implementation of
-the wayland protocol, client side.")
-    (license license:expat)))
+           rust-wayland-sys-0.29))))
 
 (define-public rust-wayland-client-0.28
   (package