summary refs log tree commit diff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-01-04 20:28:25 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:57:25 +0200
commit7a6e7b0e65be8f35099a7881120d6a60d918f5ca (patch)
tree5c29bfb1fc1e672eb42136d50b47e8d2778b3e67 /gnu/packages/crates-io.scm
parentba40456e864fcfabdc33be0325503b073603fe9c (diff)
downloadguix-7a6e7b0e65be8f35099a7881120d6a60d918f5ca.tar.gz
gnu: rust-dispatch: Move to (gnu packages crates-apple).
* gnu/packages/crates-io.scm (rust-dispatch-0.2, rust-dispatch-0.1):
Move from here ...
* gnu/packages/crates-apple.scm: ... to here.

Change-Id: Ia7452e335031b66d14359f2ef9236fd210685506
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 0 insertions, 35 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index b1235909ab..5ee6447498 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -21099,41 +21099,6 @@ memory but not other memory.  This package provides a discard trait which allows
 for intentionally leaking memory")
     (license license:expat)))
 
-(define-public rust-dispatch-0.2
-  (package
-    (name "rust-dispatch")
-    (version "0.2.0")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "dispatch" version))
-       (file-name (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32 "0fwjr9b7582ic5689zxj8lf7zl94iklhlns3yivrnv8c9fxr635x"))))
-    (build-system cargo-build-system)
-    (arguments `(#:skip-build? #t))
-    (home-page "https://github.com/SSheldon/rust-dispatch")
-    (synopsis "Rust wrapper for Apple's Grand Central Dispatch")
-    (description "This package provides a Rust wrapper for Apple's Grand
-Central Dispatch.")
-    (license license:expat)))
-
-(define-public rust-dispatch-0.1
-  (package
-    (inherit rust-dispatch-0.2)
-    (name "rust-dispatch")
-    (version "0.1.4")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (crate-uri "dispatch" version))
-       (file-name
-        (string-append name "-" version ".tar.gz"))
-       (sha256
-        (base32
-         "019nzy993hxaiazcdnayx3csv2iki34i535asw11ki96hakkrs84"))))
-    (arguments '(#:tests? #f))))  ; Tests only run on Mac.
-
 (define-public rust-displaydoc-0.2
   (package
     (name "rust-displaydoc")