summary refs log tree commit diff
path: root/gnu/packages/crates-tls.scm
diff options
context:
space:
mode:
authorVÖRÖSKŐI András <voroskoi@gmail.com>2024-02-07 16:14:55 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-02-20 13:58:39 +0200
commit0e1fda8955d7ab6edd1069ba95c4611d273f05f5 (patch)
tree2132dd1efd28822f67f58597da8d2fbda29b1621 /gnu/packages/crates-tls.scm
parent002e64d023222f273b91571336a7916e2312e663 (diff)
downloadguix-0e1fda8955d7ab6edd1069ba95c4611d273f05f5.tar.gz
gnu: Add rust-aws-lc-rs-1.
* gnu/packages/crates-tls.scm (rust-aws-lc-rs-1): New variable.

Change-Id: Ia9bb17237439f7b6dfce60a2477ab8a4759bfb49
Diffstat (limited to 'gnu/packages/crates-tls.scm')
-rw-r--r--gnu/packages/crates-tls.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/crates-tls.scm b/gnu/packages/crates-tls.scm
index d22d19b260..7a12996389 100644
--- a/gnu/packages/crates-tls.scm
+++ b/gnu/packages/crates-tls.scm
@@ -359,6 +359,39 @@ Cryptography team for AWS and their customers.  This is the FIPS validated
 version of AWS-LC.")
     (license (list license:isc license:openssl license:asl2.0))))
 
+(define-public rust-aws-lc-rs-1
+  (package
+    (name "rust-aws-lc-rs")
+    (version "1.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "aws-lc-rs" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32 "0jmwpin66yibpq0ha7i61g2ryz9gp4y6by4337fdjj2ckhwbm55v"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:tests? #f          ; Not all files included.
+       #:cargo-inputs (("rust-aws-lc-fips-sys" ,rust-aws-lc-fips-sys-0.12)
+                       ("rust-aws-lc-sys" ,rust-aws-lc-sys-0.13)
+                       ("rust-mirai-annotations" ,rust-mirai-annotations-1)
+                       ("rust-paste" ,rust-paste-1)
+                       ("rust-untrusted" ,rust-untrusted-0.7)
+                       ("rust-zeroize" ,rust-zeroize-1))
+       #:cargo-development-inputs (("rust-clap" ,rust-clap-4)
+                                   ("rust-hex" ,rust-hex-0.4)
+                                   ("rust-lazy-static" ,rust-lazy-static-1)
+                                   ("rust-regex" ,rust-regex-1))))
+    (native-inputs (list cmake-minimal))
+    (home-page "https://github.com/awslabs/aws-lc-rs")
+    (synopsis "AWS-LC is a general-purpose cryptographic library")
+    (description
+     "@code{aws-lc-rs} is a cryptographic library using AWS-LC for its
+cryptographic operations.  This library strives to be API-compatible with the
+popular Rust library named ring.")
+    (license (list license:isc license:openssl license:asl2.0))))
+
 ;; TODO: Unbundle aws-lc.
 (define-public rust-aws-lc-sys-0.13
   (package