summary refs log tree commit diff
path: root/gnu/packages/crypto.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-05-01 17:55:37 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-05-01 22:15:01 +0200
commita5006ede7fe55f51e796e881d6b20d4922d49b17 (patch)
treebad4f285dbdfab6e5e0e14b72339f00cff32f626 /gnu/packages/crypto.scm
parentf99418e3f3fa309bd0ba60d6e3e9d28b14de73c6 (diff)
downloadguix-a5006ede7fe55f51e796e881d6b20d4922d49b17.tar.gz
gnu: signify: Don't use unstable tarball.
* gnu/packages/crypto.scm (signify)[source]: Change to GIT-FETCH.
Diffstat (limited to 'gnu/packages/crypto.scm')
-rw-r--r--gnu/packages/crypto.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/crypto.scm b/gnu/packages/crypto.scm
index 2f7ea3ba8b..26d35a9e39 100644
--- a/gnu/packages/crypto.scm
+++ b/gnu/packages/crypto.scm
@@ -132,14 +132,15 @@ communication, encryption, decryption, signatures, etc.")
   (package
     (name "signify")
     (version "24")
+    (home-page "https://github.com/aperezdc/signify")
     (source (origin
-              (method url-fetch)
-              (uri (string-append "https://github.com/aperezdc/signify/"
-                                  "archive/v" version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference (url home-page)
+                                  (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "0594vyvkq176xxzaz9xbq8qs0xdnr8s9gkd1prblwpdvnzmw0xvc"))))
+                "0grdlrpxcflzmzzc30r8rvsmamvbsgqyni59flzzk4w5hpjh464w"))))
     (build-system gnu-build-system)
     ;; TODO Build with libwaive (described in README.md), to implement something
     ;; like OpenBSD's pledge().
@@ -159,7 +160,6 @@ communication, encryption, decryption, signatures, etc.")
     (description "The signify utility creates and verifies cryptographic
 signatures using the elliptic curve Ed25519.  This is a Linux port of the
 OpenBSD tool of the same name.")
-    (home-page "https://github.com/aperezdc/signify")
     ;; This package includes third-party code that was originally released under
     ;; various non-copyleft licenses. See the source files for clarification.
     (license (list license:bsd-3 license:bsd-4 license:expat license:isc