summary refs log tree commit diff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-02-28 02:03:56 -0500
committerLeo Famulari <leo@famulari.name>2017-02-28 02:09:50 -0500
commit29796b3f94b6cb5955c4e6d99afba8fe1a799bd7 (patch)
tree5c669af88a81b3e9220cc893d16ebcffb08a9738 /gnu/packages/cups.scm
parent751702676e0dcf39657082138f45340b65ae4d3e (diff)
downloadguix-29796b3f94b6cb5955c4e6d99afba8fe1a799bd7.tar.gz
gnu: cups: Fix build failure in reset-gzip-timestamps phase.
* gnu/packages/cups.scm (cups)[arguments]: Add 'make-manpages-writable' phase.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm8
1 files changed, 8 insertions, 0 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 2649cd3469..dc070fff83 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -275,6 +275,14 @@ device-specific programs to convert and print many types of files.")
                   (string-append "cupsFileFind(\"cat\", \"" catpath "\""))
                  (("cupsFileFind\\(\"cat\", \"/bin:/usr/bin\"")
                   (string-append "cupsFileFind(\"cat\", \"" catpath "\""))))))
+         ;; Make the compressed manpages writable so that the
+         ;; reset-gzip-timestamps phase does not error out.
+         (add-before 'reset-gzip-timestamps 'make-manpages-writable
+           (lambda* (#:key outputs #:allow-other-keys)
+             (let* ((out (assoc-ref outputs "out"))
+                    (man (string-append out "/share/man")))
+               (for-each (lambda (file) (chmod file #o644))
+                         (find-files man "\\.gz")))))
          (add-after 'install 'install-cups-filters-symlinks
            (lambda* (#:key inputs outputs #:allow-other-keys)
              (let ((out (assoc-ref outputs "out"))