summary refs log tree commit diff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-05-09 15:55:44 +0200
committerLudovic Courtès <ludo@gnu.org>2016-05-09 15:55:44 +0200
commit6ea06a0e3a161be52a8f0b006f29901ccf1c079a (patch)
tree3ba09337a36e5a493203b7f192923a161221433b /gnu/packages/cups.scm
parenteb354bdacbf4154ec66038dac07f19bf4ced1fad (diff)
downloadguix-6ea06a0e3a161be52a8f0b006f29901ccf1c079a.tar.gz
gnu: cups-minimal: Use 'modify-phases'.
* gnu/packages/cups.scm (cups-minimal)[arguments]: Use 'modify-phases'.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm25
1 files changed, 11 insertions, 14 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 8437170bfa..c055315321 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -135,20 +135,17 @@ filters for the PDF-centric printing workflow introduced by OpenPrinting.")
        ;; cups-filters package.
        #:tests? #f
        #:phases
-       (alist-cons-before
-        'configure
-        'patch-makedefs
-        (lambda _
-          (substitute* "Makedefs.in"
-            (("INITDIR.*=.*@INITDIR@") "INITDIR = @prefix@/@INITDIR@")
-            (("/bin/sh") (which "sh"))))
-        (alist-cons-before
-         'build
-         'patch-tests
-         (lambda _
-           (substitute* "test/ippserver.c"
-             (("#  else /\\* HAVE_AVAHI \\*/") "#elif defined(HAVE_AVAHI)")))
-         %standard-phases))))
+       (modify-phases %standard-phases
+         (add-before 'configure 'patch-makedefs
+           (lambda _
+             (substitute* "Makedefs.in"
+               (("INITDIR.*=.*@INITDIR@") "INITDIR = @prefix@/@INITDIR@")
+               (("/bin/sh") (which "sh")))))
+         (add-before 'build 'patch-tests
+           (lambda _
+             (substitute* "test/ippserver.c"
+               (("#  else /\\* HAVE_AVAHI \\*/")
+                "#elif defined(HAVE_AVAHI)")))))))
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs