summary refs log tree commit diff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-03-15 22:36:46 +0100
committerLudovic Courtès <ludo@gnu.org>2019-03-15 23:27:59 +0100
commitc9b3a72b6792c8195b0cdd8e5d7809db29419c7d (patch)
tree5f2d514dc855b220e1050d461f9ff00cb48ab1bf /gnu/packages/cups.scm
parentea843715b56c935cfb73c6fed23c31c32ec13712 (diff)
downloadguix-c9b3a72b6792c8195b0cdd8e5d7809db29419c7d.tar.gz
gnu: hplip-minimal: Remove dependency on Python & co.
This reduces the closure from 432 MiB to 160 MiB.

* gnu/packages/cups.scm (hplip-minimal)[arguments]: Pass
"--enable-lite-build" and remove 'wrap-binaries' phase.
[inputs]: Remove all things Python.
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index b943444a14..b77fb20781 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -51,7 +51,8 @@
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix utils)
-  #:use-module (srfi srfi-1))
+  #:use-module (srfi srfi-1)
+  #:use-module (ice-9 match))
 
 (define-public cups-filters
   (package
@@ -564,10 +565,19 @@ should only be used as part of the Guix cups-pk-helper service.")
     (arguments
       (substitute-keyword-arguments (package-arguments hplip)
         ((#:configure-flags cf)
-         `(delete "--enable-qt5" ,cf))))
-    (inputs
-     (fold alist-delete (package-inputs hplip)
-           '("python-pygobject" "python-pyqt")))
+         ;; Produce a "light build", meaning that only the printer (CUPS) and
+         ;; scanner (SANE) support gets built, without all the 'hp-*'
+         ;; command-line tools.
+         `(cons "--enable-lite-build"
+                (delete "--enable-qt5" ,cf)))
+        ((#:phases phases)
+         ;; The 'wrap-binaries' is not needed here since the 'hp-*' programs
+         ;; are not installed.
+         `(alist-delete 'wrap-binaries ,phases))))
+    (inputs (remove (match-lambda
+                      ((label . _)
+                       (string-prefix? "python" label)))
+                    (package-inputs hplip)))
     (synopsis "GUI-less version of hplip")))
 
 (define-public foomatic-filters