summary refs log tree commit diff
path: root/gnu/packages/cups.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-10-09 11:10:48 -0400
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:42:16 +0200
commitf59df1aa3c104aabff3291f6b8b155fb01aebc06 (patch)
tree65118f36da29df88bd6dece2e6b9f4d54089b6e2 /gnu/packages/cups.scm
parent0e881505f19bd9ea9eb543c43483f2ac45a912b3 (diff)
downloadguix-f59df1aa3c104aabff3291f6b8b155fb01aebc06.tar.gz
build-systems: gnu: Export %default-gnu-imported-modules and %default-gnu-modules.
Until now users would have to cargo cult or inspect the private
%default-modules variable of (guix build-systems gnu) to discover which
modules to include when extending the used modules via the #:modules argument.

The renaming was automated via the command:

  $ git grep -l %gnu-build-system-modules
    | xargs sed 's/%gnu-build-system-modules/%default-gnu-imported-modules/' -i

* guix/build-system/gnu.scm (%gnu-build-system-modules): Rename to...
(%default-gnu-imported-modules): ... this.
(%default-modules): Rename to...
(%default-gnu-modules): ... this.  Export.
(dist-package, gnu-build, gnu-cross-build): Adjust accordingly.

Change-Id: Idef307fff13cb76f3182d782b26e1cd3a5c757ee
Diffstat (limited to 'gnu/packages/cups.scm')
-rw-r--r--gnu/packages/cups.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/cups.scm b/gnu/packages/cups.scm
index 61da91d1f5..bf192d2b24 100644
--- a/gnu/packages/cups.scm
+++ b/gnu/packages/cups.scm
@@ -569,7 +569,7 @@ should only be used as part of the Guix cups-pk-helper service.")
     (arguments
      (list
       #:imported-modules `((guix build python-build-system)
-                           ,@%gnu-build-system-modules)
+                           ,@%default-gnu-imported-modules)
       #:modules '((guix build gnu-build-system)
                   (guix build utils)
                   ((guix build python-build-system) #:prefix python:))
@@ -888,7 +888,7 @@ HP@tie{}LaserJet, and possibly other printers.  See @file{README} for details.")
     (arguments
      (list #:modules
            `((srfi srfi-26)
-             ,@%gnu-build-system-modules)
+             ,@%default-gnu-imported-modules)
            #:configure-flags
            #~(list "--disable-static"
                    (string-append "--prefix=" #$output)
@@ -949,7 +949,7 @@ language.")
       (arguments
        `(#:modules
          ((srfi srfi-26)
-          ,@%gnu-build-system-modules)
+          ,@%default-gnu-imported-modules)
          #:make-flags
          (list (string-append "CUPSDRV="
                               (assoc-ref %outputs "out") "/share/cups/drv")