summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-11-23 10:17:00 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-11-24 12:13:01 +0100
commitb60089e837dbd81a3386f4c9236398c35fc7beb3 (patch)
tree817104e1b042c791053ef99a9cb854bcc4ce5bde /gnu/packages/databases.scm
parent7f974548ac20cab88b9bb589a5e1d85ee3b8d337 (diff)
downloadguix-b60089e837dbd81a3386f4c9236398c35fc7beb3.tar.gz
gnu: apache-arrow: Update to 6.0.1.
* gnu/packages/databases.scm (apache-arrow): Update to 6.0.1.
[arguments]: Add configuration options to disable micro-architecture
optimizations; also set ARROW_PACKAGE_KIND to Guix.
[inputs]: Move apache-thrift, lz4, zlib, and zstd from here...
[propagated-inputs]: ...to here.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm18
1 files changed, 12 insertions, 6 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 159f89ec8b..7cff0f99c5 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -3746,7 +3746,7 @@ the SQL language using a syntax that reflects the resulting query.")
 (define-public apache-arrow
   (package
     (name "apache-arrow")
-    (version "5.0.0")
+    (version "6.0.1")
     (source
      (origin
        (method git-fetch)
@@ -3756,7 +3756,7 @@ the SQL language using a syntax that reflects the resulting query.")
        (file-name (git-file-name name version))
        (sha256
         (base32
-         "0275aayzy78nbxzbj93w5152sv5q2c7020ijxnf8b58v9qwfxzz0"))))
+         "0mcw361akqw4sxnnpnr9c9v1zk4hphk6gcq763pcb19yzljh88ig"))))
     (build-system cmake-build-system)
     (arguments
      `(#:tests? #f
@@ -3795,6 +3795,10 @@ the SQL language using a syntax that reflects the resulting query.")
              "-DARROW_DEPENDENCY_SOURCE=SYSTEM"
              "-Dxsimd_SOURCE=SYSTEM"
 
+             "-DARROW_RUNTIME_SIMD_LEVEL=NONE"
+             "-DARROW_SIMD_LEVEL=NONE"
+             "-DARROW_PACKAGE_KIND=Guix"
+
              ;; Split output into its component packages.
              (string-append "-DCMAKE_INSTALL_PREFIX="
                             (assoc-ref %outputs "lib"))
@@ -3836,23 +3840,25 @@ the SQL language using a syntax that reflects the resulting query.")
              ;;"-DBENCHMARK_ENABLE_TESTING=OFF"
              "-DARROW_BUILD_STATIC=OFF")))
     (inputs
-     `(("apache-thrift" ,apache-thrift "lib")
-       ("boost" ,boost)
+     `(("boost" ,boost)
        ("brotli" ,brotli)
        ("bzip2" ,bzip2)
        ("double-conversion" ,double-conversion)
        ("gflags" ,gflags)
        ("glog" ,glog)
        ("grpc" ,grpc)
-       ("lz4" ,lz4)
        ("protobuf" ,protobuf)
        ("python-3" ,python)
        ("python-numpy" ,python-numpy)
        ("rapidjson" ,rapidjson)
        ("re2" ,re2)
        ("snappy" ,snappy)
+       ("xsimd" ,xsimd)))
+    ;; These are all listed under Requires.private in arrow.pc
+    (propagated-inputs
+     `(("apache-thrift" ,apache-thrift "lib")
+       ("lz4" ,lz4)
        ("utf8proc" ,utf8proc)
-       ("xsimd" ,xsimd)
        ("zlib" ,zlib)
        ("zstd" ,zstd "lib")))
     (native-inputs