summary refs log tree commit diff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-02-26 04:23:46 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-02-26 04:49:52 +0100
commited519b3c1fc8b3a57d86318018e93ff8822fcccd (patch)
tree050b8e32f15c4582c20e5eeaecb5df353abaca12 /gnu/packages/databases.scm
parenteddb9dacd2943301c7d1bc3cbad8df6ddab09c5a (diff)
downloadguix-ed519b3c1fc8b3a57d86318018e93ff8822fcccd.tar.gz
gnu: python-pickleshare: Update to 0.7.4.
* gnu/packages/databases.scm (python-pickleshare): Update to 0.7.4.
[source](uri): Use PYPI-URI.
[propagated-inputs]: Remove.
[properties]: Delay python2 variant.
(python2-pickleshare)[propagated-inputs]: Add PYTHON2-PATHLIB2.
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 29b6ca1698..98686910d1 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -2240,17 +2240,14 @@ SQLAlchemy Database Toolkit for Python.")
 (define-public python-pickleshare
   (package
     (name "python-pickleshare")
-    (version "0.5")
+    (version "0.7.4")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "https://pypi.python.org/packages/source/p/"
-                           "pickleshare/pickleshare-" version ".tar.gz"))
+       (uri (pypi-uri "pickleshare" version))
        (sha256
-        (base32 "11ljr90j3p6qswdrbl7p4cjb2i93f6vn0vx9anzpshsx0d2mggn0"))))
+        (base32 "0yvk14dzxk7g6qpr7iw23vzqbsr0dh4ij4xynkhnzpfz4xr2bac4"))))
     (build-system python-build-system)
-    (propagated-inputs
-     `(("python-pathpy" ,python-pathpy)))
     (home-page "https://github.com/vivainio/pickleshare")
     (synopsis "Tiny key value database with concurrency support")
     (description
@@ -2261,10 +2258,15 @@ value in database is immediately visible to other processes accessing the same
 database.  Concurrency is possible because the values are stored in separate
 files.  Hence the “database” is a directory where all files are governed by
 PickleShare.")
+    (properties `((python2-variant . ,(delay python2-pickleshare))))
     (license license:expat)))
 
 (define-public python2-pickleshare
-  (package-with-python2 python-pickleshare))
+  (let ((pickleshare (package-with-python2
+                      (strip-python2-variant python-pickleshare))))
+    (package (inherit pickleshare)
+      (propagated-inputs `(("python2-pathlib2" ,python2-pathlib2)
+                           ,@(package-propagated-inputs pickleshare))))))
 
 (define-public python-apsw
   (package