summary refs log tree commit diff
path: root/gnu/packages/debian.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:04 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-05-22 02:00:06 +0200
commit5e3cfe9f63716834ae68e8349ea28604b193fc4d (patch)
tree56da109ad145ae23a44b028668395ad33c791450 /gnu/packages/debian.scm
parent4c12fcfe43cd65c71161a4a80179cc7d336062f8 (diff)
downloadguix-5e3cfe9f63716834ae68e8349ea28604b193fc4d.tar.gz
gnu: dpkg: Update to 1.21.8 [fixes CVE-2022-1664].
* gnu/packages/debian.scm (dpkg): Update to 1.21.8.
Diffstat (limited to 'gnu/packages/debian.scm')
-rw-r--r--gnu/packages/debian.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/debian.scm b/gnu/packages/debian.scm
index 2efd8114be..62bddede02 100644
--- a/gnu/packages/debian.scm
+++ b/gnu/packages/debian.scm
@@ -336,7 +336,7 @@ other apt sources typically provided by open source developers.")
 (define-public dpkg
   (package
     (name "dpkg")
-    (version "1.21.0")
+    (version "1.21.8")
     (source
       (origin
         (method git-fetch)
@@ -345,14 +345,14 @@ other apt sources typically provided by open source developers.")
                (commit version)))
         (file-name (git-file-name name version))
         (sha256
-         (base32 "0g33cyd0qbyfdrphcw8m8ikj2hxqpjbyxbhvnp751515c8hgc4rx"))))
+         (base32 "1whb78pywdlm4v1ablgvvplqjn15b6qrwqkj0pihw5j77aakyz2s"))))
     (build-system gnu-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (add-before 'bootstrap 'patch-version
            (lambda _
-             (patch-shebang "get-version")
+             (patch-shebang "build-aux/get-version")
              (with-output-to-file ".dist-version"
                (lambda () (display ,version)))))
          (add-after 'unpack 'set-perl-libdir