summary refs log tree commit diff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-22 19:47:22 -0500
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2023-01-22 19:50:48 -0500
commit2b1e5cb6a82e60298b620ef8d2dbf90cfb925015 (patch)
tree7c8574af9cffe8d6d94091cc17a636671cdb3c17 /gnu/packages/diffoscope.scm
parente5dc6541fe0e53493289ee32efbd8571f1115470 (diff)
downloadguix-2b1e5cb6a82e60298b620ef8d2dbf90cfb925015.tar.gz
gnu: diffoscope: Simplify the build-man-page phase.
* gnu/packages/diffoscope.scm (diffoscope) [phases]: Remove MAKE-FLAGS binding
in the build-man-page phase, as the python-build-system has no such argument.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index f2f296b954..cb8e9e01b9 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -113,8 +113,8 @@
                         (("\\[\"getfacl\",")
                          (string-append "[\"" (which "getfacl") "\",")))))
                   (add-after 'build 'build-man-page
-                    (lambda* (#:key (make-flags '()) #:allow-other-keys)
-                      (apply invoke "make" "-C" "doc" make-flags)))
+                    (lambda _
+                      (invoke "make" "-C" "doc")))
                   (add-before 'check 'writable-test-data
                     (lambda _
                       ;; Tests may need write access to tests directory.