summary refs log tree commit diff
path: root/gnu/packages/direct-connect.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-01-04 16:01:58 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2022-01-05 03:54:03 +0100
commit14564f5847ae3babdc72da426801032a02334d0d (patch)
tree80657cda0130db6dfaf238a353d15324db209b01 /gnu/packages/direct-connect.scm
parentf7e6e936624c495cf138d7fc03850a2e7f2b9467 (diff)
downloadguix-14564f5847ae3babdc72da426801032a02334d0d.tar.gz
gnu: linuxdcpp: Reanimate.
* gnu/packages/direct-connect.scm (linuxdcpp)[source]: Add patch and
snippet to fix build.
* gnu/packages/patches/linuxdcpp-openssl-1.1.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/direct-connect.scm')
-rw-r--r--gnu/packages/direct-connect.scm18
1 files changed, 16 insertions, 2 deletions
diff --git a/gnu/packages/direct-connect.scm b/gnu/packages/direct-connect.scm
index 87bf0a7c8a..d342537122 100644
--- a/gnu/packages/direct-connect.scm
+++ b/gnu/packages/direct-connect.scm
@@ -1,5 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2017 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -18,9 +19,11 @@
 
 (define-module (gnu packages direct-connect)
   #:use-module (guix build-system scons)
+  #:use-module (guix gexp)
   #:use-module ((guix licenses) #:prefix license:)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (gnu packages)
   #:use-module (gnu packages boost)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages gettext)
@@ -42,8 +45,19 @@
              "https://launchpad.net/linuxdcpp/1.1/1.1.0/+download/linuxdcpp-"
              version ".tar.bz2"))
        (sha256
-        (base32
-         "12i92hirmwryl1qy0n3jfrpziwzb82f61xca9jcjwyilx502f0b6"))))
+        (base32 "12i92hirmwryl1qy0n3jfrpziwzb82f61xca9jcjwyilx502f0b6"))
+       (patches (search-patches "linuxdcpp-openssl-1.1.patch"))
+       (modules '((guix build utils)))
+       (snippet
+        #~(begin
+            (substitute* "SConstruct"
+              ;; This compares single char[]acters in the version string, and
+              ;; broke when GCC went into double digits.
+              (("conf.CheckCXXVersion\\([^\\)]*\\)")
+               "True")
+              ;; Not all valid C++98 code is valid C++14 (and higher) code.
+              (("'-D_REENTRANT'" match)
+               (string-append match ", '-std=gnu++98'")))))))
     (build-system scons-build-system)
     (arguments
      `(#:scons ,scons-python2