summary refs log tree commit diff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 10:22:01 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-04-06 13:14:44 +0100
commit0243721fb932c9226169b7fb00ebf8fb3f68519c (patch)
treeef331f0fda9ee445f6a6860040c77109e9d58f09 /gnu/packages/disk.scm
parent34e21fac4fb25a6714e1cb378cdb5a698bd88923 (diff)
downloadguix-0243721fb932c9226169b7fb00ebf8fb3f68519c.tar.gz
gnu: lf: Update to 31.
* gnu/packages/disk.scm (lf): Update to 31.
[arguments] <#:go>: Use go-1.18.
[native-inputs]: Remove go-github-com-gdamore-tcell-v2-2.3; add
go-github-com-gdamore-tcell-v2 and go-github-com-djherbis-times.

* gnu/packages/golang.scm (go-github-com-gdamore-tcell-v2-2.3): Remove
variable.

Change-Id: I02f675eeb74a2a08dd153ca64619bd6a8f23943c
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 82b311f459..6f602d645f 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -1295,8 +1295,7 @@ on your file system and offers to remove it.  @command{rmlint} can find:
 (define-public lf
   (package
     (name "lf")
-    ;; When updating, remove go-github-com-gdamore-tcell-v2-2.3 from golang.scm.
-    (version "27")
+    (version "31")
     (source (origin
               (method git-fetch)
               (uri (git-reference
@@ -1305,13 +1304,15 @@ on your file system and offers to remove it.  @command{rmlint} can find:
               (file-name (git-file-name name version))
               (sha256
                (base32
-                "1piym8za0iw2s8yryh39y072f90mzisv89ffvn1jzb71f71mbfqa"))))
+                "03icsf4c3j7295s1d8s6srz5gf09a3lghgw3zfcd86p03zhkzsaf"))))
     (build-system go-build-system)
     (native-inputs
      (list go-github-com-mattn-go-runewidth go-golang-org-x-term
-           go-gopkg-in-djherbis-times-v1 go-github-com-gdamore-tcell-v2-2.3))
+           go-gopkg-in-djherbis-times-v1 go-github-com-gdamore-tcell-v2
+           go-github-com-djherbis-times))
     (arguments
-     `(#:import-path "github.com/gokcehan/lf"))
+     `(#:go ,go-1.18
+       #:import-path "github.com/gokcehan/lf"))
     (home-page "https://github.com/gokcehan/lf")
     (synopsis "Console file browser similar to Ranger")
     (description "lf (as in \"list files\") is a terminal file manager