summary refs log tree commit diff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>2016-02-02 08:04:34 +0100
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-02-05 09:30:29 +0100
commit0f860464bd37e0a67a8c64b6139859ee91aaa460 (patch)
tree57948f4d67f27e780842f2feb76411a39c05a3ee /gnu/packages/disk.scm
parentb9da375999e2d7030944d4271a68fccfb15c1e20 (diff)
downloadguix-0f860464bd37e0a67a8c64b6139859ee91aaa460.tar.gz
gnu: Add sdparm.
* gnu/packages/disk.scm (sdparm): New variable.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index d806e0c1cd..b9240a392a 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -2,6 +2,7 @@
 ;;; Copyright © 2012, 2013 Nikita Karetnikov <nikita@karetnikov.org>
 ;;; Copyright © 2015 Mathieu Lirzin <mthl@gnu.org>
 ;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Tobias Geerinckx-Rice <tobias.geerinckx.rice@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -144,3 +145,29 @@ to recover data more efficiently by only reading the necessary blocks.")
      "The dosfstools package includes the mkfs.fat and fsck.fat utilities,
 which respectively make and check MS-DOS FAT filesystems.")
     (license gpl3+)))
+
+(define-public sdparm
+  (package
+    (name "sdparm")
+    (version "1.09")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "http://sg.danny.cz/sg/p/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "0jakqyjwi72zqjzss04bally0xl0lc4710mx8da08vpmir1hfphg"))))
+    (build-system gnu-build-system)
+    (home-page "http://sg.danny.cz/sg/sdparm.html")
+    (synopsis "Provide access to SCSI device parameters")
+    (description
+     "Sdparm reads and modifies SCSI device parameters.  These devices can be
+SCSI disks, in which case the role of @command{sdparm} is similar to its
+namesake: the @command{hdparm} utility originally designed for ATA disks.
+However, @command{sdparm} can be used to access parameters on any device that
+uses a SCSI command set.  Such devices include CD/DVD drives (irrespective of
+transport), SCSI and ATAPI tape drives, and SCSI enclosures.  This utility can
+also send commands associated with starting and stopping the media, loading
+and unloading removable media and some other housekeeping functions.")
+    (license bsd-3)))