summary refs log tree commit diff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:05 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2022-06-12 02:00:00 +0200
commit67ff6767925d35c9d3a3c83cd21083ca8f930f02 (patch)
treeae293707abfddc6e03c5e3a7de12a767e2800fee /gnu/packages/disk.scm
parent824f2afcf0ffa7d515b04e360fa49a6b0c4a7753 (diff)
downloadguix-67ff6767925d35c9d3a3c83cd21083ca8f930f02.tar.gz
gnu: python-parted: Update to 3.12.0.
* gnu/packages/disk.scm (python-parted): Update to 3.12.0.
[arguments]: Run the default 'check phase at the default time.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm16
1 files changed, 2 insertions, 14 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 8886d1c2a2..5524792188 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -718,7 +718,7 @@ a card with a smaller capacity than stated.")
 (define-public python-parted
   (package
     (name "python-parted")
-    (version "3.11.7")
+    (version "3.12.0")
     (source
      (origin
        (method git-fetch)
@@ -727,20 +727,8 @@ a card with a smaller capacity than stated.")
              (commit (string-append "v" version))))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "01193fmkss9icjvqpw85szpk8ld1pnha7p9kqm7mpwk6rc6gi2m3"))))
+        (base32 "0jxc1i1g3lz32wvqvdbb9ng2ypin783004kjnp0pghiz813lpw1d"))))
     (build-system python-build-system)
-    (arguments
-     `(#:phases
-       (modify-phases %standard-phases
-         (delete 'check)
-         (add-after 'install 'check
-           (lambda* (#:key outputs inputs #:allow-other-keys)
-             (add-installed-pythonpath inputs outputs)
-             ;; See <https://github.com/dcantrell/pyparted/issues/47>.
-             (substitute* "tests/test__ped_ped.py"
-               (("\"/tmp/temp-device-\"") "self.path"))
-             (invoke "python" "-m" "unittest" "discover" "-v")
-             #t)))))
     (native-inputs
      (list e2fsprogs pkg-config))
     (propagated-inputs