summary refs log tree commit diff
path: root/gnu/packages/disk.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-06-02 15:50:17 -0400
committerLeo Famulari <leo@famulari.name>2019-06-12 15:46:53 -0400
commitff22ff42a1d759eafd94e596c7a610e8fd9eb001 (patch)
treeaf9c6ac358e39a3cd903b4e245cf424579ca1b00 /gnu/packages/disk.scm
parentac72162efd9245400573e7255834c2b77b96a3bc (diff)
downloadguix-ff22ff42a1d759eafd94e596c7a610e8fd9eb001.tar.gz
gnu: GParted: Update 1.0.0.
* gnu/packages/disk.scm (gparted): Update to 1.0.0.
[arguments]: Remove obsolete configure flag.
[inputs]: Use gtkmm@3. Add yelp-tools and itstool. Remove libxslt,
gnome-doc-utils, docbook-xml-4.2, python-2, python2-libxml2, and which.
[native-inputs]: Add lvm2.
Diffstat (limited to 'gnu/packages/disk.scm')
-rw-r--r--gnu/packages/disk.scm22
1 files changed, 11 insertions, 11 deletions
diff --git a/gnu/packages/disk.scm b/gnu/packages/disk.scm
index 491f7ce881..778529436b 100644
--- a/gnu/packages/disk.scm
+++ b/gnu/packages/disk.scm
@@ -13,6 +13,7 @@
 ;;; Copyright © 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
 ;;; Copyright © 2018, 2019 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -341,32 +342,31 @@ and can dramatically shorten the lifespan of the drive if left unchecked.")
 (define-public gparted
   (package
     (name "gparted")
-    (version "0.33.0")
+    (version "1.0.0")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "mirror://sourceforge/gparted/gparted/gparted-"
                            version "/gparted-" version ".tar.gz"))
        (sha256
-        (base32 "1ml1ky3s75lbxr91p608q3prsdh9x899mw7nbgk252pqhg4vh8sh"))))
+        (base32
+         "0mdvn85jvy72ff7nds3dakx9kzknh8gx1z8i0w2sf970q03qp2z4"))))
     (build-system gnu-build-system)
     (arguments
-     `(#:tests? #f                      ; tests require a network connection
-       #:configure-flags '("--disable-scrollkeeper")))
+      ;; Tests require access to paths outside the build container, such
+      ;; as '/dev/disk/by-id'
+     `(#:tests? #f))
     (inputs
      `(("util-linux" ,util-linux)
        ("parted" ,parted)
        ("glib" ,glib)
-       ("gtkmm" ,gtkmm-2)
+       ("gtkmm" ,gtkmm)
        ("libxml2" ,libxml2)
-       ("libxslt" ,libxslt)
-       ("gnome-doc-utils" ,gnome-doc-utils)
-       ("docbook-xml" ,docbook-xml-4.2)
-       ("python" ,python-2)
-       ("python-libxml2" ,python2-libxml2)
-       ("which" ,which)))
+       ("yelp-tools" ,yelp-tools)
+       ("itstool" ,itstool)))
     (native-inputs
      `(("intltool" ,intltool)
+       ("lvm2" ,lvm2) ; for tests
        ("pkg-config" ,pkg-config)))
     (home-page "https://gparted.org/")
     (synopsis "Partition editor to graphically manage disk partitions")