summary refs log tree commit diff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2017-11-16 07:57:55 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2017-11-21 02:53:01 +0100
commit023ef01354671f28e88b1dd3e6f4cf9fefb6f6d9 (patch)
tree188836bc29d65151f387888951de3287a561b03a /gnu/packages/dns.scm
parent7e685deeb72cb2ec4bbb647799d57b4e4d91dbd7 (diff)
downloadguix-023ef01354671f28e88b1dd3e6f4cf9fefb6f6d9.tar.gz
gnu: knot: Support dnstap query logging.
* gnu/packages/dns.scm (knot)[source]: No longer delete dnstap.  It appears
that dnstap is intended to be bundled and modified.
[inputs]: Add fstrm and protobuf-c.
[arguments]: Add ‘--with-module-dnstap=yes’ to #:configure-flags.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm14
1 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index b06cde71b4..c1cdb613a5 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -494,20 +494,16 @@ Extensions} (DNSSEC).")
               (modules '((guix build utils)))
               (snippet
                '(begin
-                  ;; Remove bundled libraries and dependencies on them.
-                  (substitute* "configure"
-                    (("src/contrib/dnstap/Makefile") ""))
-                  (substitute* "src/Makefile.in"
-                    (("contrib/dnstap ") ""))
+                  ;; Delete bundled libraries.
                   (with-directory-excursion "src/contrib"
-                    (for-each delete-file-recursively
-                              (list "dnstap" "lmdb")))
+                    (delete-file-recursively "lmdb"))
                   #t))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
     (inputs
-     `(("gnutls" ,gnutls)
+     `(("fstrm" ,fstrm)
+       ("gnutls" ,gnutls)
        ("jansson" ,jansson)
        ("libcap-ng" ,libcap-ng)
        ("libedit" ,libedit)
@@ -516,6 +512,7 @@ Extensions} (DNSSEC).")
        ("lmdb" ,lmdb)
        ("ncurses" ,ncurses)
        ("nettle" ,nettle)
+       ("protobuf-c" ,protobuf-c)
 
        ;; For ‘pykeymgr’, needed to migrate keys from versions <= 2.4.
        ("python" ,python-2)
@@ -548,6 +545,7 @@ Extensions} (DNSSEC).")
        (list "--sysconfdir=/etc"
              "--localstatedir=/var"
              "--with-module-rosedb=yes" ; serve static records from a database
+             "--with-module-dnstap=yes" ; allow detailed query logging
              (string-append "--with-bash-completions="
                             (assoc-ref %outputs "out")
                             "/etc/bash_completion.d"))))