summary refs log tree commit diff
path: root/gnu/packages/dns.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2021-12-09 01:18:03 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2021-12-09 01:24:37 +0100
commit4ca0e9d5f77ec309a5a8a7eba3d97fd3bb4852d5 (patch)
tree9c451d9d3085f1e28ebe8ec87aa0cd82800d0111 /gnu/packages/dns.scm
parente5e307b6768088e35be0c7526f25a3e16d93c242 (diff)
downloadguix-4ca0e9d5f77ec309a5a8a7eba3d97fd3bb4852d5.tar.gz
gnu: bind: Update to 9.16.23 [fixes CVE-2021-25218, CVE-2021-25219].
* gnu/packages/dns.scm (isc-bind): Update to 9.16.23.
[source]: Add patch.
* gnu/packages/patches/bind-re-add-attr-constructor-priority.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/dns.scm')
-rw-r--r--gnu/packages/dns.scm20
1 files changed, 11 insertions, 9 deletions
diff --git a/gnu/packages/dns.scm b/gnu/packages/dns.scm
index 0c2e037b4f..c4c4bd2b3a 100644
--- a/gnu/packages/dns.scm
+++ b/gnu/packages/dns.scm
@@ -373,15 +373,17 @@ and BOOTP/TFTP for network booting of diskless machines.")
     ;; When updating, check whether isc-dhcp's bundled copy should be as well.
     ;; The BIND release notes are available here:
     ;; https://www.isc.org/bind/
-    (version "9.16.16")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append
-                    "https://ftp.isc.org/isc/bind9/" version
-                    "/bind-" version ".tar.xz"))
-              (sha256
-               (base32
-                "0yqxfq7qc26x7qhk0nkp8h7x9jggzaafm712bvfffy7qml13k4bc"))))
+    (version "9.16.23")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://ftp.isc.org/isc/bind9/" version
+             "/bind-" version ".tar.xz"))
+       (sha256
+        (base32 "0g0pxzhzcz6nzkiab4cs9sgbjdzqgy44aa477v7akdlwm8kmxnyy"))
+       (patches
+        (search-patches "bind-re-add-attr-constructor-priority.patch"))))
     (build-system gnu-build-system)
     (outputs `("out" "utils"))
     (inputs