summary refs log tree commit diff
path: root/gnu/packages/easyrpg.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2018-11-13 21:36:01 +0800
committer宋文武 <iyzsong@member.fsf.org>2018-12-09 09:11:13 +0800
commitb779dbac721a008647a7fd646a3e19cbbb6b0e73 (patch)
treebe390f52c35aea5079d288db8dcdc53f71f02257 /gnu/packages/easyrpg.scm
parentb05399dffc5c7d25fe46c8c7070708b0e6ea4fc2 (diff)
downloadguix-b779dbac721a008647a7fd646a3e19cbbb6b0e73.tar.gz
gnu: Add liblcf.
* gnu/packages/easyrpg.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
Diffstat (limited to 'gnu/packages/easyrpg.scm')
-rw-r--r--gnu/packages/easyrpg.scm62
1 files changed, 62 insertions, 0 deletions
diff --git a/gnu/packages/easyrpg.scm b/gnu/packages/easyrpg.scm
new file mode 100644
index 0000000000..6844f83ded
--- /dev/null
+++ b/gnu/packages/easyrpg.scm
@@ -0,0 +1,62 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Sou Bunnbu <iyzsong@member.fsf.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages easyrpg)
+  #:use-module (guix packages)
+  #:use-module ((guix licenses) #:prefix license:)
+  #:use-module (guix download)
+  #:use-module (guix build-system gnu)
+  #:use-module (gnu packages icu4c)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages xml))
+
+(define-public liblcf
+  (package
+    (name "liblcf")
+    (version "0.5.4")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append
+                    "https://easyrpg.org/downloads/player/" version
+                    "/liblcf-" version ".tar.gz"))
+              (sha256
+               (base32
+                "1k99bcw5c23801jk3mbz5sj5h18x46w1qxrkknhwhfgqzpvxhwrs"))))
+    (build-system gnu-build-system)
+    (native-inputs
+     `(("pkg-config" ,pkg-config)))
+    (propagated-inputs
+     ;; Required by 'liblcf.pc'.
+     `(("expat" ,expat)
+       ("icu" ,icu4c)))
+    (home-page "https://easyrpg.org/")
+    (synopsis "Library to handle RPG Maker 2000 and 2003 game data")
+    (description
+     "@code{liblcf} is a library to handle RPG Maker 2000 and 2003 game data.
+It can read and write LCF and XML files.")
+    ;; It includes a copy of Boost Preprocessor Cat and Stringize (boost-1.0):
+    ;;   src/boost/preprocessor/config.hpp
+    ;;   src/boost/preprocessor/cat.hpp
+    ;;   src/boost/preprocessor/stringize.hpp
+    ;; and a copy of inih (bsd-3):
+    ;;   src/ini.h
+    ;;   src/ini.cpp
+    ;;   src/inireader.h
+    ;;   src/inireader.cpp
+    ;; TODO: Unbundle them.
+    (license license:expat)))