summary refs log tree commit diff
path: root/gnu/packages/ebook.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-11-26 17:53:36 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-11-26 20:44:40 +0100
commit39aa75baecafd350e76fe0146948942a183df4ee (patch)
treea091d7b9ec4771f45010ead0502aa59bc9300f81 /gnu/packages/ebook.scm
parent42aaa350c3752ab24317422149e74d8a3dbe7543 (diff)
downloadguix-39aa75baecafd350e76fe0146948942a183df4ee.tar.gz
gnu: cozy: Update to 0.7.6.
* gnu/packages/ebook.scm (cozy): Update to 0.7.6.
[arguments]: Adjust 'patch-desktop-file phase.
[inputs]: Add libhandy.  Remove python-apsw.
Diffstat (limited to 'gnu/packages/ebook.scm')
-rw-r--r--gnu/packages/ebook.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/ebook.scm b/gnu/packages/ebook.scm
index 1609a631b7..b7b2113db4 100644
--- a/gnu/packages/ebook.scm
+++ b/gnu/packages/ebook.scm
@@ -415,7 +415,7 @@ following formats:
 (define-public cozy
   (package
     (name "cozy")
-    (version "0.7.2")
+    (version "0.7.6")
     (source
      (origin
        (method git-fetch)
@@ -424,7 +424,7 @@ following formats:
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0fmbddi4ga0bppwg3rm3yjmf7jgqc6zfslmavnr1pglbzkjhy9fs"))))
+        (base32 "1pg0djhg4p32vxfwf6bfals31zf93m56fx1x4q5jhhdwmll7xl6w"))))
     (build-system meson-build-system)
     (arguments
      `(#:glib-or-gtk? #t
@@ -432,7 +432,7 @@ following formats:
        (modify-phases %standard-phases
          (add-after 'unpack 'patch-desktop-file
            (lambda _
-             (substitute* "data/com.github.geigi.cozy.desktop.in"
+             (substitute* "data/com.github.geigi.cozy.desktop"
                (("Exec=com.github.geigi.cozy") "Exec=cozy"))
              #t))
          (add-after 'install 'patch-executable-name
@@ -477,7 +477,7 @@ following formats:
        ("gst-plugins-good" ,gst-plugins-good)
        ("gst-plugins-ugly" ,gst-plugins-ugly)
        ("gtk+" ,gtk+)
-       ("python-apsw" ,python-apsw)
+       ("libhandy" ,libhandy)
        ("python-distro" ,python-distro)
        ("python-gst" ,python-gst)
        ("python-mutagen" ,python-mutagen)