summary refs log tree commit diff
path: root/gnu/packages/elm.scm
diff options
context:
space:
mode:
authorPhilip McGrath <philip@philipmcgrath.com>2022-05-18 14:11:13 -0400
committerLudovic Courtès <ludo@gnu.org>2022-05-22 01:07:55 +0200
commit297ae57bed14abc5f949f36e6b98bad0f5a86993 (patch)
tree42fd1a28971ca47dd15a65237cb7279a56c920ae /gnu/packages/elm.scm
parent4522741c1d5746d159b82f6203735b80b8f88ab8 (diff)
downloadguix-297ae57bed14abc5f949f36e6b98bad0f5a86993.tar.gz
gnu: Add elm-explorations-test.
* gnu/packages/elm.scm (elm-explorations-test): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/elm.scm')
-rw-r--r--gnu/packages/elm.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/elm.scm b/gnu/packages/elm.scm
index c2e4b65b77..edd13a0b8a 100644
--- a/gnu/packages/elm.scm
+++ b/gnu/packages/elm.scm
@@ -578,3 +578,28 @@ of rendered elements.")
      "Need to generate random numbers?  How about random game boards?  Or
 random positions in 3D space?  This is the package for you!")
     (license license:bsd-3)))
+
+(define-public elm-explorations-test
+  (package
+    (name "elm-explorations-test")
+    (version "1.2.2")
+    (source
+     (elm-package-origin
+      "elm-explorations/test"
+      version
+      (base32 "0kw32x0lr6nh5j9xk56vgg7x7c705g38grghh7cdp49frwdd6w3l")))
+    (build-system elm-build-system)
+    (propagated-inputs
+     (list elm-virtual-dom
+           elm-random
+           elm-json
+           elm-html
+           elm-core))
+    (home-page
+     "https://package.elm-lang.org/packages/elm-explorations/test/1.2.2")
+    (synopsis "Testing framework for Elm")
+    (description "This package enables writing unit and fuzz tests for Elm
+code.  To actually run the tests, you need the command-line tool from
+@url{https://github.com/rtfeldman/node-test-runner}, which has not yet been
+packaged for Guix.")
+    (license license:bsd-3)))