summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-14 00:32:53 +0200
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-08-14 00:32:53 +0200
commit51deacd8604b59aa434e944c73aecefd5183d13e (patch)
tree7429b8652ce656f883e8277ec95e273d88fe0fe3 /gnu/packages/emacs-xyz.scm
parent3349a50d700a2112a31ac4ce6cc6639d3b4cf1e2 (diff)
parentbe6f5edd445850720dfcec2642db643b84fc0645 (diff)
downloadguix-51deacd8604b59aa434e944c73aecefd5183d13e.tar.gz
Merge branch 'master' into emacs-team
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm81
1 files changed, 78 insertions, 3 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 58a53bfee3..1a44926729 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -9052,6 +9052,30 @@ completion candidate when using the Company text completion framework.")
 @code{company-math}.")
     (license license:gpl3+)))
 
+(define-public emacs-math-preview
+  (package
+    (name "emacs-math-preview")
+    (version "5.1.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri
+        (git-reference
+         (url "https://gitlab.com/matsievskiysv/math-preview")
+         (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "0ni08900p0pbajw143iw0b7a62qiqcm9b6jy7pqgpn437vydjx1z"))))
+    (build-system emacs-build-system)
+    (propagated-inputs (list emacs-dash emacs-s))
+    (home-page "https://gitlab.com/matsievskiysv/math-preview")
+    (synopsis "Preview TeX math equations inline using MathJax")
+    (description
+     "Emacs math-preview uses MathJax for displaying TeX, MathML and AsciiMath
+  math inline in Emacs buffers.")
+    (license license:gpl3+)))
+
 (define-public emacs-company-coq
   (package
     (name "emacs-company-coq")
@@ -12208,6 +12232,32 @@ The following completions are currently available:
 @end itemize")
     (license license:gpl3+)))
 
+(define-public emacs-sway
+  ;; Commit from Nicola's fork (dash free version with various improvments)
+  (let ((commit "838ef531a30fe616f0141adbdabc132d4edfd374")
+        (revision "0"))
+    (package
+      (name "emacs-sway")
+      (version (git-version "0.6.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/thblt/sway.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0ddaz8my3z4ca2z81kf1h8773pyx8h0l0ra3ssqd1rq5j0041wdh"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/thblt/sway.el")
+      (synopsis "Communication with the Sway window manager")
+      (description
+       "This is a basic library to control the Sway window manager from Emacs.
+Its main use case is in combination with popup managers like Shackle, to
+use frames instead of windows while still giving focus to existing frames
+instead of duplicating them.")
+      (license license:gpl3+))))
+
 (define-public emacs-sweet-theme
   (let ((commit "78f741806ecebe01224bf54d09ad80e306652508")
         (revision "0"))
@@ -23865,7 +23915,7 @@ within Emacs.")
 (define-public emacs-ibrowse
   (package
     (name "emacs-ibrowse")
-    (version "0.1.8")
+    (version "0.2.2")
     (source
      (origin
        (method git-fetch)
@@ -23874,9 +23924,9 @@ within Emacs.")
              (commit version)))
        (file-name (git-file-name name version))
        (sha256
-        (base32 "0q3imid9byaay0lqvv5n2klwk680w8x3qzdb279rdr08bb36w5ya"))))
+        (base32 "1dm46k67smg2m33c6n68blpw2mw7fx1ymq81kv54jjlpmv3xrdsf"))))
     (build-system emacs-build-system)
-    (inputs (list sqlite))
+    (inputs (list emacs-websocket sqlite))
     (home-page "https://git.sr.ht/~ngraves/ibrowse.el")
     (synopsis "Interact with your browser from emacs")
     (description "This package provides some commands to act on the browser
@@ -37525,6 +37575,31 @@ clipboard and inserts an Org mode link with a title of a page found by the URL
 into the current buffer.")
       (license license:expat))))
 
+(define-public emacs-org-wild-notifier
+  (let ((commit "cdca8be45b80ab52077a915e77c625bc0ad07dd7")
+        (revision "0"))
+    (package
+      (name "emacs-org-wild-notifier")
+      (version (git-version "0.4.1" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/akhramov/org-wild-notifier.el")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32
+           "0k37ac752r5whjha4mf9qg74g65kf71a2dlpl4wlxvdml5v1czw1"))))
+      (build-system emacs-build-system)
+      (propagated-inputs
+       (list emacs-dash emacs-alert emacs-async))
+      (license license:gpl3+)
+      (home-page "https://github.com/akhramov/org-wild-notifier.el")
+      (synopsis "Customizable org-agenda notifications")
+      (description
+       "This package provides notification functions for org-agenda."))))
+
 (define-public emacs-flymake-mypy
   (let ((commit "d79e158f9ed3065ab692cd0d4048aac985c4fecd")
         (revision "0"))