summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorAndrew Jose <arnav.jose@gmail.com>2023-10-17 20:07:29 +0530
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-01-22 00:20:48 +0100
commit661d29894c9860eba7061215352c8a533347422b (patch)
tree11d111015854918df3c8eeffa306606c29192269 /gnu/packages/emacs-xyz.scm
parente775f704c8da973ca42f7f0fe962f692cbf74652 (diff)
downloadguix-661d29894c9860eba7061215352c8a533347422b.tar.gz
gnu: Add emacs-flexoki-themes.
* gnu/packages/emacs-xyz.scm (emacs-flexoki-themes): New variable.

Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
Change-Id: Ic69965014234ef7c6ef2276bd7f100b466a8b327
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9cb2dec98c..03cec6267d 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -2545,6 +2545,28 @@ programs.")
 supports type hints, definition-jumping, completion, and more.")
     (license license:gpl3+)))
 
+(define-public emacs-flexoki-themes
+  (let ((commit "1b871e57e989d58a793cbfef7b4996a6bd47ba9f")) ;version bump
+    (package
+      (name "emacs-flexoki-themes")
+      (version "0.20")
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/crmsnbleyd/flexoki-emacs-theme")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0npl45h1l8jhrd5dcaaql5in4pj7c3wxnqsp8di668pz2s4i9pfh"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/crmsnbleyd/flexoki-emacs-theme")
+      (synopsis "Inky colour scheme for prose and code")
+      (description
+       "Flexoki themes is a pair of light and dark themes for GNU Emacs based
+on the Flexoki colour scheme by Steph Ango.")
+      (license license:gpl3+))))
+
 (define-public emacs-flycheck
   (package
     (name "emacs-flycheck")