summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-01 21:35:30 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-09-01 22:21:52 +0200
commit7bca9465f2781a14ccb334a6c1a98972ac533e21 (patch)
treee894ef5da62b3e32df0f93d14ecfe7435dc9431f /gnu/packages/emacs-xyz.scm
parentbbf87d7efdbe094c4a8399bc12aee8348173cb9e (diff)
downloadguix-7bca9465f2781a14ccb334a6c1a98972ac533e21.tar.gz
gnu: emacs-dashboard: Update to 1.8.0.
* gnu/packages/emacs-xyz.scm (emacs-dashboard): Update to 1.8.0.
[arguments]<#:phases>: Remove an unnecessary phase.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm54
1 files changed, 21 insertions, 33 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2a11928ee9..9df9b58dbf 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25280,40 +25280,28 @@ Emacs minor mode to escape sequences in code.")
       (license license:gpl3+))))
 
 (define-public emacs-dashboard
-  (let ((version "1.7.0")
-        (commit "a69cc103aebd957f967e431399681b6d9d6b52fc")
-        (revision "0"))
-    (package
-      (name "emacs-dashboard")
-      (version (git-version version revision commit))
-      (source
-       (origin
-         (method git-fetch)
-         (uri (git-reference
-               (url "https://github.com/rakanalh/emacs-dashboard")
-               (commit commit)))
-         (file-name (git-file-name name version))
-         (sha256
-          (base32 "1c6snnpc9rp6zhhdz411wyh2wn56yq2cdmxxqsp1ibvac8cbb1pq"))))
-      (build-system emacs-build-system)
-      (arguments
-       (list
-        #:include #~(cons* "\\.txt$" "\\.png$" %default-include)
-        #:phases
-        #~(modify-phases %standard-phases
-            (add-after 'unpack 'patch-dashboard-widgets
-              ;; This phase fixes compilation error.
-              (lambda _
-                (emacs-substitute-variables "dashboard-widgets.el"
-                  ("dashboard-init-info"
-                   '(format "Loaded in %s" (emacs-init-time)))))))))
-      (propagated-inputs
-       (list emacs-page-break-lines))
-      (home-page "https://github.com/rakanalh/emacs-dashboard")
-      (synopsis "Startup screen extracted from Spacemacs")
-      (description "This package provides an extensible Emacs dashboard, with
+  (package
+    (name "emacs-dashboard")
+    (version "1.8.0")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/rakanalh/emacs-dashboard")
+             (commit version)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1m39alr4vi22wr0yd22yi3qkdykwh8vmkdlbbd8qm9z1g7mvl382"))))
+    (build-system emacs-build-system)
+    (arguments
+     (list #:include #~(cons* "\\.txt$" "\\.png$" %default-include)))
+    (propagated-inputs
+     (list emacs-page-break-lines))
+    (home-page "https://github.com/rakanalh/emacs-dashboard")
+    (synopsis "Startup screen extracted from Spacemacs")
+    (description "This package provides an extensible Emacs dashboard, with
 sections for bookmarks, Projectile projects, Org Agenda and more.")
-      (license license:gpl3+))))
+    (license license:gpl3+)))
 
 (define-public emacs-slime-company
   (package