summary refs log tree commit diff
path: root/gnu/packages/emacs-xyz.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-10-03 22:02:01 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-10-03 22:09:33 +0200
commit8e6022732ab6c4ba256f99d925f5fd413a87372c (patch)
tree285f94b3719ea56da5147c368a0e3d2a9352ccf0 /gnu/packages/emacs-xyz.scm
parent761cc5ae232120e944f6afb9b91ee26e2205a969 (diff)
downloadguix-8e6022732ab6c4ba256f99d925f5fd413a87372c.tar.gz
gnu: emacs-yeetube: Improve package style.
* gnu/packages/emacs-xyz.scm (emacs-yeetube): Fix indentation.
[synopsis, description]: Use Texinfo markup.  Add proper capitalization.
Diffstat (limited to 'gnu/packages/emacs-xyz.scm')
-rw-r--r--gnu/packages/emacs-xyz.scm49
1 files changed, 24 insertions, 25 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 0676b4c01f..878574ff45 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -27919,20 +27919,20 @@ and comments.")
 
 (define-public emacs-yeetube
   (package
-   (name "emacs-yeetube")
-   (version "2.0.4")
-   (source
-    (origin
-     (method git-fetch)
-     (uri (git-reference
-           (url "https://git.thanosapollo.com/yeetube")
-           (commit version)))
-     (sha256
-      (base32
-       "175yz46gql27y2v02apa1zyzgparzpgrsmw1mbb1nlx0cnf7an79"))
-     (file-name (git-file-name name version))))
-   (build-system emacs-build-system)
-   (arguments
+    (name "emacs-yeetube")
+    (version "2.0.4")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://git.thanosapollo.com/yeetube")
+             (commit version)))
+       (sha256
+        (base32
+         "175yz46gql27y2v02apa1zyzgparzpgrsmw1mbb1nlx0cnf7an79"))
+       (file-name (git-file-name name version))))
+    (build-system emacs-build-system)
+    (arguments
      (list
       #:phases
       #~(modify-phases %standard-phases
@@ -27944,17 +27944,16 @@ and comments.")
               (substitute* "yeetube-mpv.el"
                 (("\\(executable-find \"mpv\"\\)")
                  (search-input-file inputs "/bin/mpv"))))))))
-   (inputs
-    (list mpv yt-dlp))
-   (home-page "https://thanosapollo.com/blog/yeetube/")
-   (synopsis "Youtube & Invidious front-end for Emacs")
-   (description
-    "This package offers an Emacs interface that allows you to search YouTube
-or an Invidious instance for a specific query.  The search results are shown as
-links in an org-mode buffer.  The videos can be opened to a user-defined video
-player(by default mpv) or downloaded using yt-dlp.  This package also includes
-a yt-dlp front-end.")
-   (license license:gpl3+)))
+    (inputs (list mpv yt-dlp))
+    (home-page "https://thanosapollo.com/blog/yeetube/")
+    (synopsis "Youtube and Invidious front-end for Emacs")
+    (description
+     "This package offers an Emacs interface that allows you to search YouTube
+or an Invidious instance for a specific query.  The search results are shown
+as links in an Org mode buffer.  The videos can be opened to a user-defined
+video player (by default @command{mpv}) or downloaded using @command{yt-dlp}.
+This package also includes a @code{yt-dlp} front-end.")
+    (license license:gpl3+)))
 
 (define-public emacs-org-web-tools
   (package