summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2017-05-07 15:18:02 +0530
committerArun Isaac <arunisaac@systemreboot.net>2017-05-10 16:04:13 +0530
commit2406766e79264139ae75d006da2e09258c32e1b7 (patch)
tree2a0e7e5d50cd7d27e5beaa563b24f403246d7787 /gnu/packages/emacs.scm
parentf66f7b92bd7963337da0cdf647f694f5cd86ea71 (diff)
downloadguix-2406766e79264139ae75d006da2e09258c32e1b7.tar.gz
gnu: Add emacs-evil-commentary.
* gnu/packages/emacs.scm (emacs-evil-commentary): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f4cdd64b8a..41fc240e19 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -4622,3 +4622,27 @@ pressed simultaneously or a single key quickly pressed twice.")
     (description "@code{emacs-evil-surround} allows easy deletion, change and
 addition of surrounding pairs, such as parantheses and quotes, in evil mode.")
     (license license:gpl3+)))
+
+(define-public emacs-evil-commentary
+  (package
+    (name "emacs-evil-commentary")
+    (version "2.1.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://github.com/linktohack/evil-commentary/archive/v"
+             version ".tar.gz"))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1jdya0i921nwskwrzdsj0vrr3m7gm49dy6f6pk9p5nxaarfxk230"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-evil" ,emacs-evil)))
+    (home-page "https://github.com/linktohack/evil-commentary")
+    (synopsis "Comment out code in evil mode")
+    (description "@code{emacs-evil-commentary} adds keybindings to easily
+comment out lines of code in evil mode.  It provides @code{gcc} to comment out
+lines, and @code{gc} to comment out the target of a motion.")
+    (license license:gpl3+)))