summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-09-26 16:35:37 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-26 23:40:36 +0200
commit2a5f2b1f7550db701172a338e98179e1cac55a1c (patch)
tree5ee99ecfde8be04501ecf95b5c8fa730b625d98c /gnu/packages/emacs.scm
parent4245ddcbc9f935804c17c97872b90ec1050c2d75 (diff)
downloadguix-2a5f2b1f7550db701172a338e98179e1cac55a1c.tar.gz
gnu: Remove incorrect Emacs package deprecations.
This is a followup to 5c8031ff7382ec9079040d08ae5a05b4dd2352b7.  An
upgrade would wrongfully report things like:

  guix package: package 'emacs-typo' has been superseded by 'emacs-typo'
  guix package: package 'emacs-org-tree-slide' has been superseded by 'emacs-org-tree-slide'
  guix package: package 'emacs-emms' has been superseded by 'emacs-emms'

* gnu/packages/emacs.scm (flycheck, emms, typo, org-tree-slide)
(butler): Remove.
(emacs-emms-mode-line-cycle)[propagated-inputs]: Use EMACS-EMMS instead
of EMMS.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm17
1 files changed, 1 insertions, 16 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c541c51483..9dc11c59fc 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -782,9 +782,6 @@ different tools.  It highlights errors and warnings inline in the buffer, and
 provides an optional IDE-like error list.")
     (license license:gpl3+)))                     ;+GFDLv1.3+ for the manual
 
-(define-public flycheck
-  (deprecated-package "flycheck" emacs-flycheck))
-
 
 ;;;
 ;;; Web browsing.
@@ -1066,9 +1063,6 @@ light user interface.")
     (home-page "https://www.gnu.org/software/emms/")
     (license license:gpl3+)))
 
-(define-public emms
-  (deprecated-package "emacs-emms" emacs-emms))
-
 (define-public emacs-emms-player-mpv
   ;; A new mpv backend is included in Emms from 5.0.
   (deprecated-package "emacs-emms-player-mpv" emacs-emms))
@@ -1088,7 +1082,7 @@ light user interface.")
          "0ifszi930pnaxk1x8pcydmvnp06868gc7nfx14q17zbajbx735k6"))))
     (build-system emacs-build-system)
     (propagated-inputs
-     `(("emms" ,emms)))
+     `(("emms" ,emacs-emms)))
     (home-page "https://github.com/momomo5717/emms-mode-line-cycle")
     (synopsis "Display the EMMS mode line as a ticker")
     (description
@@ -2722,9 +2716,6 @@ view the build status of those servers' build jobs, and possibly to trigger
 build jobs.")
     (license license:gpl3+)))
 
-(define-public butler
-  (deprecated-package "emacs-butler" emacs-butler))
-
 (define-public emacs-company
   (package
     (name "emacs-company")
@@ -2874,9 +2865,6 @@ automatically inserts a Unicode opening or closing quotation mark, depending
 on context.")
     (license license:gpl3+)))
 
-(define-public typo
-  (deprecated-package "emacs-typo" emacs-typo))
-
 (define-public emacs-scheme-complete
   (let ((commit "9b5cf224bf2a5994bc6d5b152ff487517f1a9bb5"))
     (package
@@ -8061,9 +8049,6 @@ navigation with the grails mode.")
 @kbd{C-<} to jump to the next and previous slide.")
       (license license:gpl3+))))
 
-(define-public org-tree-slide
-  (deprecated-package "emacs-org-tree-slide" emacs-org-tree-slide))
-
 (define-public emacs-scratch-el
   (let ((commit "2cdf2b841ce7a0987093f65b0cc431947549f897")
         (revision "1"))