summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-02-27 11:53:06 -0500
committerMark H Weaver <mhw@netris.org>2015-02-28 09:49:01 -0500
commit722ec722441a755e18fbc696d23441427dfb26af (patch)
tree8d429f0ec1b30d692ab24bc07838e47b4cb33ab8 /gnu/packages/emacs.scm
parentdd0a8ef15f903422c6b020e7d793986427add927 (diff)
downloadguix-722ec722441a755e18fbc696d23441427dfb26af.tar.gz
gnu: Move autoconf-style phases after the unpack phase.
* gnu/packages/audio.scm (soundtouch)[arguments]: Move 'bootstrap'
  after 'unpack'.  Remove custom /usr/bin/file patching, which will
  now be handled by the 'patch-usr-bin-file' phase.
* gnu/packages/emacs.scm (emacs-w3m)[arguments]: Rename 'pre-configure'
  phase to 'autoconf' and move it after 'unpack'.
* gnu/packages/fontutils.scm (libuninameslist)[arguments]: Move 'bootstrap'
  phase after 'unpack'.
* gnu/packages/libevent.scm (libuv)[arguments]: Move 'autogen' phase after
  'unpack'.  Run "sh autogen.sh" instead of "./autogen.sh".
* gnu/packages/linux.scm (bridge-utils)[arguments]: Move 'bootstrap' phase
  after 'unpack'.
* gnu/packages/mail.scm (libetpan)[arguments]: Move 'autogen' phase after
  'unpack'.  Run "sh autogen.sh" instead of "./autogen.sh".  Setenv
  "NOCONFIGURE" before running autogen.sh.
* gnu/packages/package-management.scm (guix-devel)[arguments]: Move
  'bootstrap' phase after 'unpack'.  Run "sh autogen.sh" instead of
  "./autogen.sh".
* gnu/packages/rdf.scm (lrdf)[arguments]: Move 'autoreconf' phase after
  'remove-out-of-tree-references' phase.
* gnu/packages/tor.scm (privoxy)[arguments]: Move 'autoconf' phase after
  'unpack'.
* gnu/packages/web.scm (libpsl)[arguments]: Move 'bootstrap' phase after
  'unpack'.  Run "sh autogen.sh" instead of "./autogen.sh".  Remove
  'fix-autogen-shebang' phase.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index f4d7ac9748..b2a151a68e 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -309,8 +309,8 @@ operations.")
                               out "/share/images/emacs-w3m")))
        #:tests? #f  ; no check target
        #:phases
-       (alist-cons-before
-        'configure 'pre-configure
+       (alist-cons-after
+        'unpack 'autoconf
         (lambda _
           (zero? (system* "autoconf")))
         (alist-cons-before