summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorAndrew Tropin <andrew@trop.in>2022-09-16 15:53:53 +0300
committerAndrew Tropin <andrew@trop.in>2022-09-16 20:28:34 +0300
commit77e768ac4e57d5fd443c7d69a7cc0c8339d0c238 (patch)
treedee75cf1c29691e79adc3723f6e3ab9d968e55ea /gnu/packages/emacs.scm
parent888dfc8eb6f08672de716dc66a15a74fee302eb7 (diff)
downloadguix-77e768ac4e57d5fd443c7d69a7cc0c8339d0c238.tar.gz
gnu: emacs-next-pgtk: Fix super key problem.
Recent version of emacs 29 with pgtk flag has a problem with handling super
key modifier, due to gtk bug: https://gitlab.gnome.org/GNOME/gtk/-/issues/4913
This commit workarounds it.

* gnu/packages/patches/emacs-pgtk-super-key-fix.patch: New file.
* gnu/packages/emacs.scm (emacs-next-pgtk): Use it here.
* gnu/local.mk (dist_patch_DATA): Register it here.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index ef6e9ae1f1..fc93852880 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -409,6 +409,10 @@ languages.")
   (package
     (inherit emacs-next)
     (name "emacs-next-pgtk")
+    (source
+     (origin
+       (inherit (package-source emacs-next))
+       (patches (search-patches "emacs-pgtk-super-key-fix.patch"))))
     (arguments
      (substitute-keyword-arguments (package-arguments emacs-next)
        ((#:configure-flags flags #~'())