summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorClément Lassieur <clement@lassieur.org>2017-05-06 10:30:22 +0200
committerClément Lassieur <clement@lassieur.org>2017-05-12 10:38:42 +0200
commit864704212f4af3fba2ade784f9ac175bb685d53f (patch)
treeb8dccc03b1deee58607cdb507dccaf643dadc59f /gnu/packages/emacs.scm
parentd231fe0a9b6354e281c916e3d91207f1648534e1 (diff)
downloadguix-864704212f4af3fba2ade784f9ac175bb685d53f.tar.gz
gnu: emacs-ag: Propagate the-silver-searcher.
This allows emacs-ag to be used on remote systems.

* gnu/packages/emacs.scm (emacs-ag)[inputs]: Remove.  Move THE-SILVER-SEARCHER
to...
[propagated-inputs]: ... here.
[arguments]: Remove 'patch-exec-paths' phase.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm13
1 files changed, 3 insertions, 10 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 6e095caadd..21120b3314 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -1125,13 +1125,6 @@ than @code{electric-indent-mode}.")
     (arguments
      `(#:phases
        (modify-phases %standard-phases
-         (add-before 'install 'patch-exec-paths
-           (lambda* (#:key inputs #:allow-other-keys)
-             (emacs-substitute-variables "ag.el"
-               ("ag-executable"
-                (string-append (assoc-ref inputs "the-silver-searcher")
-                               "/bin/ag")))
-             #t))
          (add-before 'install 'make-info
            (lambda _
              (with-directory-excursion "docs"
@@ -1142,14 +1135,14 @@ than @code{electric-indent-mode}.")
                     (info (string-append out "/share/info")))
                (install-file "docs/_build/texinfo/agel.info" info)
                #t))))))
-    (inputs
-     `(("the-silver-searcher" ,the-silver-searcher)))
     (native-inputs
      `(("python-sphinx" ,python-sphinx)
        ("texinfo" ,texinfo)))
     (propagated-inputs
      `(("dash" ,emacs-dash)
-       ("s" ,emacs-s)))
+       ("s" ,emacs-s)
+       ;; We need to use 'ag' as the executable on remote systems.
+       ("the-silver-searcher" ,the-silver-searcher)))
     (home-page "https://github.com/Wilfred/ag.el")
     (synopsis "Front-end for ag (the-silver-searcher) for Emacs")
     (description "This package provides the ability to use the silver