summary refs log tree commit diff
path: root/gnu/packages/emacs.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-09-06 11:21:51 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2018-09-12 22:48:04 -0400
commitf309671c289373893096de367c779f3175f297da (patch)
treeffc79d0b2e79a91cb4a8870fbaceb0393eb69e61 /gnu/packages/emacs.scm
parent82baeea2979b98a642dcfe63a87d08355a101f4c (diff)
downloadguix-f309671c289373893096de367c779f3175f297da.tar.gz
gnu: Add emacs-org-reveal.
* gnu/packages/emacs.scm (emacs-org-reveal): New variable.
Diffstat (limited to 'gnu/packages/emacs.scm')
-rw-r--r--gnu/packages/emacs.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 1541626d76..770ca3c496 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -9812,6 +9812,29 @@ The default setup uses helm-bibtex.
 You should really read org-ref.org in this package for details.")
       (license license:gpl3+))))
 
+(define-public emacs-org-reveal
+  (package
+    (name "emacs-org-reveal")
+    ;; There are no proper tag, so we use the latest commit of the stable
+    ;; branch, as does MELPA.
+    (version "20161027.926")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/yjwen/org-reveal.git")
+                    (commit "001567cc12d50ba07612edd1718b86a12e8c2547")))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "18rma8smjrskbjyna076zhvx79zs5r5vinb537h8mw13pfxd6cm8"))))
+    (build-system emacs-build-system)
+    (home-page "https://github.com/yjwen/org-reveal")
+    (synopsis "Org and Reveal.js powered HTML presentation tool")
+    (description "Org-Reveal is a command@{org-mode} extension that allows to
+create beautiful presentations (slides) with 3D effects from simple but
+powerful Org contents.")
+    (license license:gpl3+)))
+
 (define-public emacs-add-hooks
   (package
     (name "emacs-add-hooks")