summary refs log tree commit diff
path: root/gnu/packages/enchant.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-12-13 17:18:24 +0100
committerLudovic Courtès <ludo@gnu.org>2021-12-13 17:48:25 +0100
commit8394619baceb118df92e355377fd543bb1aa501a (patch)
tree504f07c2a9f88596a305b59ef45f941062426a52 /gnu/packages/enchant.scm
parentaca2defe0172868295941fd9f0e97886f6e9b2d4 (diff)
downloadguix-8394619baceb118df92e355377fd543bb1aa501a.tar.gz
gnu: Simplify package inputs.
This commit was obtained by running:

  ./pre-inst-env guix style

without any additional argument.
Diffstat (limited to 'gnu/packages/enchant.scm')
-rw-r--r--gnu/packages/enchant.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/enchant.scm b/gnu/packages/enchant.scm
index f32e59ef54..62d6e90ed4 100644
--- a/gnu/packages/enchant.scm
+++ b/gnu/packages/enchant.scm
@@ -65,9 +65,9 @@
        ;;("ronn" ,ronn)
        ("pkg-config" ,pkg-config)))
     (inputs
-     `(("boost" ,boost)))
+     (list boost))
     (propagated-inputs
-     `(("icu4c" ,icu4c)))
+     (list icu4c))
     (synopsis "Fast and safe spellchecking C++ library")
     (description "Nuspell is a fast and safe spelling checker software
 program.  It is designed for languages with rich morphology and complex word
@@ -94,11 +94,10 @@ dictionaries.")
                            ;; Tests require a relocatable build.
                            "--enable-relocatable")))
     (inputs
-     `(("aspell" ,aspell)
-       ("hunspell" ,hunspell)))
+     (list aspell hunspell))
     (propagated-inputs
      ;; Required by enchant.pc.
-     `(("glib" ,glib)))
+     (list glib))
     (native-inputs
      `(("glib:bin" ,glib "bin")
        ("pkg-config" ,pkg-config)
@@ -157,7 +156,7 @@ working\".")
                                "    yield \"" (assoc-ref inputs "enchant")
                                "/lib/libenchant-2.so\""))))))))
     (inputs
-     `(("enchant" ,enchant)))
+     (list enchant))
     (home-page "https://github.com/pyenchant/pyenchant")
     (synopsis "Spellchecking library for Python")
     (description "PyEnchant is a spellchecking library for Python, based on the