summary refs log tree commit diff
path: root/gnu/packages/engineering.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-26 11:25:00 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-30 10:37:01 +0200
commit595b53b74e3ef57a1c0c96108ba86d38a170a241 (patch)
treeca55848d693980d988fb87cf9db8bfd22a5b819d /gnu/packages/engineering.scm
parent60ef511147a33afc317aeeb0f2c8650c6699fdb1 (diff)
downloadguix-595b53b74e3ef57a1c0c96108ba86d38a170a241.tar.gz
gnu: Add emacs-poke.
* gnu/packages/engineering.scm (emacs-poke): New variable.
(poke)[arguments]: Add configure-flag to install emacs files to
temporary directory.
Diffstat (limited to 'gnu/packages/engineering.scm')
-rw-r--r--gnu/packages/engineering.scm22
1 files changed, 21 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index ff997a140d..14beec9d28 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2903,7 +2903,9 @@ program that can perform mesh processing tasks in batch mode, without a GUI.")
      ;; To enable the "hyperlink server", add the `--enable-hserver' flag.
      `(#:configure-flags
        '("--enable-mi"
-         "--disable-static")))
+         "--disable-static"
+         ;; The emacs files are provided in emacs-poke.
+         "--with-lispdir=/tmp/share/emacs")))
     (home-page "https://www.gnu.org/software/poke/#documentation")
     (synopsis "Editing of arbitrary binary data")
     (description "GNU poke is an interactive, extensible editor for binary data.
@@ -2912,6 +2914,24 @@ full-fledged procedural, interactive programming language designed to describe
 data structures and to operate on them.")
     (license license:gpl3+)))
 
+(define-public emacs-poke
+  (package
+    (inherit poke)
+    (name "emacs-poke")
+    (build-system emacs-build-system)
+    (arguments
+     (list
+       #:phases
+       #~(modify-phases %standard-phases
+           (add-before 'expand-load-path 'change-working-directory
+             (lambda _ (chdir "etc"))))))
+    (inputs '())
+    (native-inputs '())
+    (synopsis "GNU Poke major modes for Emacs")
+    (description
+     "This package provides two Emacs major modes for working with GNU Poke:
+@code{Poke Ras mode} and @code{Poke Map mode}.")))
+
 (define-public pcb2gcode
   ;; Take some additional commits after v2.4.0 to fix build against
   ;; geos 3.10.1.