summary refs log tree commit diff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-05-08 19:44:35 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-05-08 19:55:13 +0300
commit944bdb2afe1e13dd3da345744f5f4437aca43b0f (patch)
tree09a14558855a47030053786cbe2e9475dd6727b6 /gnu/packages/enlightenment.scm
parent3ec29587b550b6c3590edcb651fa8f7688558d50 (diff)
downloadguix-944bdb2afe1e13dd3da345744f5f4437aca43b0f.tar.gz
gnu: terminology: Update build.
* gnu/packages/enlightenment.scm (terminology)[arguments]: Add to
configure-flags.  Add custom 'set-home-directory phase.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index a70193c8d4..419bcbd564 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -203,7 +203,10 @@ removable devices or support for multimedia.")
                   #t))))
     (build-system meson-build-system)
     (arguments
-     `(#:configure-flags '("-Dtests=true")
+     `(#:configure-flags (list "-Dtests=true"
+                               (string-append "-Dedje-cc="
+                                              (assoc-ref %build-inputs "efl")
+                                              "/bin/edje_cc"))
        #:phases
        (modify-phases %standard-phases
          (add-after 'unpack 'set-home-directory
@@ -286,6 +289,7 @@ Libraries with some extra bells and whistles.")
        (modify-phases %standard-phases
          (add-before 'configure 'set-system-actions
            (lambda* (#:key inputs #:allow-other-keys)
+            (setenv "HOME" "/tmp")
              (let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
                    (setxkbmap (assoc-ref inputs "setxkbmap"))
                    (utils     (assoc-ref inputs "util-linux"))