summary refs log tree commit diff
path: root/gnu/packages/enlightenment.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2021-04-25 21:37:52 +0200
committerLudovic Courtès <ludo@gnu.org>2021-04-25 23:35:04 +0200
commitc09e331b25e35dc435af67765a9bdb2e8f4aa296 (patch)
treef37376eba5a7cbcbf23134fc64279043a31059ae /gnu/packages/enlightenment.scm
parent69afc5fd2351b2665fdfa7db5b14a70ac96925ba (diff)
downloadguix-c09e331b25e35dc435af67765a9bdb2e8f4aa296.tar.gz
gnu: xfce, mate: Propagate 'font-dejavu'.
Fixes <https://bugs.gnu.org/47713>.
Reported by bo0od <bo0od@riseup.net>.

This ensures applications such as IceCat can properly text (numbers in
the case of IceCat).

* gnu/packages/enlightenment.scm (enlightenment)[propagated-inputs]: Add
FONT-DEJAVU.
* gnu/packages/mate.scm (mate)[propagated-inputs]: New field.
* gnu/packages/xfce.scm (xfce)[propagated-inputs]: New field.
Diffstat (limited to 'gnu/packages/enlightenment.scm')
-rw-r--r--gnu/packages/enlightenment.scm6
1 files changed, 5 insertions, 1 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 15ea89454f..079d60e45a 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -36,6 +36,7 @@
   #:use-module (gnu packages code)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
+  #:use-module (gnu packages fonts)
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages freedesktop)
   #:use-module (gnu packages fribidi)
@@ -370,7 +371,10 @@ Libraries with some extra bells and whistles.")
     (propagated-inputs
      `(("efl" ,efl)
        ("libxkbcommon" ,libxkbcommon)
-       ("wayland-protocols" ,wayland-protocols)))
+       ("wayland-protocols" ,wayland-protocols)
+
+       ;; Default font that applications such as IceCat require.
+       ("font-dejavu" ,font-dejavu)))
     (home-page "https://www.enlightenment.org/about-enlightenment")
     (synopsis "Lightweight desktop environment")
     (description