summary refs log tree commit diff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorIgor Goryachev via Guix-patches via <guix-patches@gnu.org>2024-08-07 19:32:10 +0300
committerAndrew Tropin <andrew@trop.in>2024-08-09 04:54:19 +0400
commit13b15c5e8934208b6d2f94151f1a157a5a24d622 (patch)
tree5bee44b6b300b9f5357c0d41a785d3f1fd92b869 /gnu/packages/erlang.scm
parentd029fef8452505f9ad4a8902d99501bb44aa3559 (diff)
downloadguix-13b15c5e8934208b6d2f94151f1a157a5a24d622.tar.gz
gnu: erlang-yamerl: Update to 0.10.0-0.a24f448.
* gnu/packages/erlang.scm (erlang-yamerl): Update to 0.10.0-0.a24f448.

Change-Id: Ib279881ff14e6e46ef639c1bcbc53706fa55aef6
Signed-off-by: Andrew Tropin <andrew@trop.in>
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm41
1 files changed, 22 insertions, 19 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 60d644ab8d..80ec673a56 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -290,26 +290,29 @@ printing extending the io:format syntax to add colours.")
     (license license:expat)))
 
 (define-public erlang-yamerl
-  (package
-    (name "erlang-yamerl")
-    (version "0.10.0")
-    (source
-     (origin
-       (method git-fetch)
-       (uri (git-reference
-             ;; There are no tests included on Hex.
-             (url "https://github.com/yakaz/yamerl")
-             (commit (string-append "v" version))))
-       (file-name (git-file-name name version))
-       (sha256
-        (base32 "0if8abgmispcfk7zhd0a5dndzwzbsmqrbyrm5shk375r2dbbwak6"))))
-    (build-system rebar-build-system)
-    (synopsis "YAML and JSON parser in pure Erlang")
-    (description
-     "Erlang application to parse YAML 1.1 and YAML 1.2 documents, as well as
+  (let ((commit "a24f448c0a8084f70b751dc38621047e56fb53cc")
+        (revision "0"))
+    (package
+      (name "erlang-yamerl")
+      (version (git-version "0.10.0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               ;; There are no tests included on Hex.
+               (url "https://github.com/yakaz/yamerl")
+               ;; Fetching commit which includes Erlang 27+ related fixes.
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1csq0z4igyybjgmrynz4d49ysv437iyd2xzkhifb5x47lpdpfpkq"))))
+      (build-system rebar-build-system)
+      (synopsis "YAML and JSON parser in pure Erlang")
+      (description
+       "Erlang application to parse YAML 1.1 and YAML 1.2 documents, as well as
 JSON documents.")
-    (home-page "https://hexdocs.pm/yamerl/")
-    (license license:bsd-2)))
+      (home-page "https://hexdocs.pm/yamerl/")
+      (license license:bsd-2))))
 
 (define-public erlang-covertool
   (package