summary refs log tree commit diff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-05-23 23:18:41 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2021-10-07 22:35:29 +0200
commit1a9063843cfcca9ef6f8aceb65427154a41839a4 (patch)
treee9500b4dd1cc64abfc9b5cfb21e64c8930a520d5 /gnu/packages/erlang.scm
parent8b9b1b3819786442e4df2bb4446ec3cdfe47c1f0 (diff)
downloadguix-1a9063843cfcca9ef6f8aceb65427154a41839a4.tar.gz
gnu: Add erlang-relx.
* gnu/packages/erlang.scm (erlang-relx): New variable.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 8f60f4be30..fcb7ba65b5 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -445,6 +445,32 @@ Erlang.")
     (description "This package provides an Erlang providers library.")
     (license license:asl2.0)))
 
+(define-public erlang-relx
+  (package
+    (name "erlang-relx")
+    (version "4.5.0")
+    (source
+     (origin
+       (method hexpm-fetch)
+       (uri (hexpm-uri "relx" version))
+       (sha256
+        (base32 "12fjcb5b992ixxkc7v7v55ln1i5qak7dzmzqvf6hx50l1ip3hh58"))))
+    (build-system rebar3-build-system)
+    (propagated-inputs
+     `(("erlang-bbmustache" ,erlang-bbmustache)
+       ("erlang-cf" ,erlang-cf)
+       ("erlang-erlware-commons" ,erlang-erlware-commons)
+       ("erlang-getopt" ,erlang-getopt)
+       ("erlang-providers" ,erlang-providers)))
+    (home-page "https://erlware.github.io/relx/")
+    (synopsis "Release assembler for Erlang/OTP Releases")
+    (description "Relx assembles releases for an Erlang/OTP release.  Given a
+release specification and a list of directories in which to search for OTP
+applications it will generate a release output.  That output depends heavily on
+what plugins available and what options are defined, but usually it is simply
+a well configured release directory.")
+    (license license:asl2.0)))
+
 (define-public erlang-ssl-verify-fun
   (package
     (name "erlang-ssl-verify-fun")