summary refs log tree commit diff
path: root/gnu/packages/erlang.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-07-03 16:43:01 +0200
committerHartmut Goebel <h.goebel@crazy-compilers.com>2022-06-15 10:18:48 +0200
commite0376bc8a4acb721300b4b898460a44e1e04b7dc (patch)
treeec7a5c9db7377c5c34aa534a632d4d24de513a47 /gnu/packages/erlang.scm
parent4af9fa11308f294ad1fa254140dea2c0fb2c9495 (diff)
downloadguix-e0376bc8a4acb721300b4b898460a44e1e04b7dc.tar.gz
gnu: Add erlang-edown.
* gnu/packages/erlang.scm (erlang-edown): New variable.
Diffstat (limited to 'gnu/packages/erlang.scm')
-rw-r--r--gnu/packages/erlang.scm17
1 files changed, 17 insertions, 0 deletions
diff --git a/gnu/packages/erlang.scm b/gnu/packages/erlang.scm
index 9318b0b953..1ce61e5d7d 100644
--- a/gnu/packages/erlang.scm
+++ b/gnu/packages/erlang.scm
@@ -300,6 +300,23 @@ printing extending the io:format syntax to add colours.")
 outputs you want to be readable around all that noise they contain.")
     (license license:bsd-3)))
 
+(define-public erlang-edown
+  (package
+    (name "erlang-edown")
+    (version "0.8.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (hexpm-uri "edown" version))
+        (sha256
+          (base32 "0ij47gvgs6yfqphj0f54qjzj18crj8y1dsjjlzpp3dp8pscqzbqw"))))
+    (build-system rebar-build-system)
+    (home-page "https://github.com/uwiger/edown")
+    (synopsis "Markdown extension for EDoc")
+    (description "This package provides an extension for EDoc for generating
+Markdown.")
+    (license license:asl2.0)))
+
 (define-public erlang-erlware-commons
   (package
     (name "erlang-erlware-commons")