summary refs log tree commit diff
path: root/gnu/packages/fcitx5.scm
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-06-22 20:16:54 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:12 +0800
commit2f9032b2e72038f1d99293cf28054eca601a1c67 (patch)
tree322fcb9b893d07370f7ad9ad22133ad2751881ce /gnu/packages/fcitx5.scm
parent3e43f7a57102ef65b06263d2e97e1bfbb3b56a35 (diff)
downloadguix-2f9032b2e72038f1d99293cf28054eca601a1c67.tar.gz
gnu: fcitx5-qt: Use new style.
* gnu/packages/fcitx5.scm (fcitx5-qt)[arguments]: Use Gexp.
[inputs]: Remove label.

Change-Id: Ie47b0d7f0f1184351ffa5df919bfc16aff5e42c9
Diffstat (limited to 'gnu/packages/fcitx5.scm')
-rw-r--r--gnu/packages/fcitx5.scm34
1 files changed, 16 insertions, 18 deletions
diff --git a/gnu/packages/fcitx5.scm b/gnu/packages/fcitx5.scm
index c555b8ab84..6a5b06ef75 100644
--- a/gnu/packages/fcitx5.scm
+++ b/gnu/packages/fcitx5.scm
@@ -318,24 +318,22 @@ IM module for GTK+3 applications.
         (base32 "0jdisavns5k718vrnh2lmmyrnys101szbw107d200nfl4i26wllj"))))
     (build-system cmake-build-system)
     (arguments
-     `(#:configure-flags
-       (list (string-append "-DCMAKE_INSTALL_QT5PLUGINDIR="
-                            %output "/lib/qt5/plugins")
-             (string-append "-DCMAKE_INSTALL_QT6PLUGINDIR="
-                            %output "/lib/qt6/plugins")
-             "-DENABLE_QT4=Off"
-             "-DENABLE_QT6=ON")))
-    (inputs
-     `(("fcitx5" ,fcitx5)
-       ("libxcb" ,libxcb)
-       ("libxkbcommon" ,libxkbcommon)
-       ("qtbase-5" ,qtbase-5)
-       ("qtbase" ,qtbase)
-       ("qtwayland" ,qtwayland)
-       ("wayland" ,wayland)
-       ("gettext" ,gettext-minimal)))
-    (native-inputs
-     (list extra-cmake-modules))
+     (list #:configure-flags
+           #~(list (string-append "-DCMAKE_INSTALL_QT5PLUGINDIR="
+                                  #$output "/lib/qt5/plugins")
+                   (string-append "-DCMAKE_INSTALL_QT6PLUGINDIR="
+                                  #$output "/lib/qt6/plugins")
+                   "-DENABLE_QT4=Off"
+                   "-DENABLE_QT6=ON")))
+    (inputs (list fcitx5
+                  libxcb
+                  libxkbcommon
+                  qtbase-5
+                  qtbase
+                  qtwayland
+                  wayland
+                  gettext-minimal))
+    (native-inputs (list extra-cmake-modules))
     (home-page "https://github.com/fcitx/fcitx5-qt")
     (synopsis "Qt library and IM module for Fcitx 5")
     (description "Fcitx5-qt provides Qt library for development and IM module