summary refs log tree commit diff
path: root/gnu/packages/file.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-11-22 12:24:41 +0100
committerLudovic Courtès <ludo@gnu.org>2014-11-22 12:24:41 +0100
commit0253ab39794ce5d9cf051ac70c632c378a732d8e (patch)
tree9ba07487b9a549d931a254389374cffffdc9e267 /gnu/packages/file.scm
parenta5b60e3c6bfec96092a7854edb0c74fb46eed647 (diff)
downloadguix-0253ab39794ce5d9cf051ac70c632c378a732d8e.tar.gz
gnu: file: Update to 5.20.
* gnu/packages/file.scm (file): Update to 5.20.
  (file-5.20): Remove.
* gnu/packages/patches/file-CVE-2014-3587.patch: Remove.
* gnu-system.am (dist_patch_DATA): Adjust accordingly.
* gnu/packages/patchutils.scm (quilt): Use FILE instead of FILE-5.20.
* gnu/packages/version-control.scm (aegis): Ditto.
Diffstat (limited to 'gnu/packages/file.scm')
-rw-r--r--gnu/packages/file.scm26
1 files changed, 8 insertions, 18 deletions
diff --git a/gnu/packages/file.scm b/gnu/packages/file.scm
index 070695ec2c..7d8504b74a 100644
--- a/gnu/packages/file.scm
+++ b/gnu/packages/file.scm
@@ -27,14 +27,14 @@
 (define-public file
   (package
    (name "file")
-   (version "5.19")
-   (source (origin
-            (method url-fetch)
-            (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
-                   version ".tar.gz"))
-            (sha256 (base32
-                     "0z1sgrcfy6d285kj5izy1yypf371bjl3247plh9ppk0svaxv714l"))
-            (patches (list (search-patch "file-CVE-2014-3587.patch")))))
+    (version "5.20")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0iyjs9z8kp43gz7gva4j67h4p0n53f7q8x3ibai9s01sp3xnphsv"))))
    (build-system gnu-build-system)
 
    ;; When cross-compiling, this package depends upon a native install of
@@ -50,13 +50,3 @@ of the file.")
    (license bsd-2)
    (home-page "http://www.darwinsys.com/file/")))
 
-(define-public file-5.20                          ;fix for CVE-2014-3710
-  (package (inherit file)
-    (version "5.20")
-    (source (origin
-              (method url-fetch)
-              (uri (string-append "ftp://ftp.astron.com/pub/file/file-"
-                                  version ".tar.gz"))
-              (sha256
-               (base32
-                "0iyjs9z8kp43gz7gva4j67h4p0n53f7q8x3ibai9s01sp3xnphsv"))))))