summary refs log tree commit diff
path: root/gnu/packages/finance.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-11-06 18:15:28 -0500
committerChristopher Baines <mail@cbaines.net>2020-11-18 08:44:43 +0000
commitfa268b28e1ccc392c85846810d836034c96df3c0 (patch)
treecbb36d852b0e3eec80abf67301a8b8b2210acfc0 /gnu/packages/finance.scm
parent5a6c861db98a7ca7a1ccaea59f9463878228f9af (diff)
downloadguix-fa268b28e1ccc392c85846810d836034c96df3c0.tar.gz
gnu: bitcoin-core: Update to 0.20.1.
* gnu/packages/finance.scm (bitcoin-core): Update to 0.20.1.
[source]: Remove obsolete patch.
[native-inputs]: Add autoconf, automake and libtool.
[inputs]: Remove protobuf.
[arguments]: Add "set-no-git-flag" phase to indicate the build is not taking
place within a git repository.
* gnu/packages/patches/bitcoin-core-python-compat.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Christopher Baines <mail@cbaines.net>
Diffstat (limited to 'gnu/packages/finance.scm')
-rw-r--r--gnu/packages/finance.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 7b87bde50c..7ef40f544f 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -108,7 +108,7 @@
 (define-public bitcoin-core
   (package
     (name "bitcoin-core")
-    (version "0.19.1")
+    (version "0.20.1")
     (source (origin
               (method url-fetch)
               (uri
@@ -116,11 +116,13 @@
                               version "/bitcoin-" version ".tar.gz"))
               (sha256
                (base32
-                "1h3w7brc18145np920vy7j5ms5hym59hvr40swdjx34fbdaisngj"))
-              (patches (search-patches "bitcoin-core-python-compat.patch"))))
+                "0y5rad68b398arh0abr2wgiwybdw0i5a4dxz9s3fk9fgdbyn5gab"))))
     (build-system gnu-build-system)
     (native-inputs
-     `(("pkg-config" ,pkg-config)
+     `(("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("libtool" ,libtool)
+       ("pkg-config" ,pkg-config)
        ("python" ,python)               ; for the tests
        ("util-linux" ,util-linux)       ; provides the hexdump command for tests
        ("qttools" ,qttools)))
@@ -130,7 +132,6 @@
        ("libevent" ,libevent)
        ("miniupnpc" ,miniupnpc)
        ("openssl" ,openssl)
-       ("protobuf" ,protobuf)
        ("qtbase" ,qtbase)))
     (arguments
      `(#:configure-flags
@@ -154,6 +155,13 @@
              ;; Make Qt deterministic.
              (setenv "QT_RCC_SOURCE_DATE_OVERRIDE" "1")
              #t))
+         (add-before 'build 'set-no-git-flag
+           (lambda _
+             ;; Make it clear we are not building from within a git repository
+             ;; (and thus no information regarding this build is available
+             ;; from git).
+             (setenv "BITCOIN_GENBUILD_NO_GIT" "1")
+             #t))
          (add-before 'check 'set-home
            (lambda _
              (setenv "HOME" (getenv "TMPDIR")) ; tests write to $HOME